Foxpro executable does not show up

I have an application, which runs as an executable just fine on one of my computers. However, on another computer, also with Win 7 Pro, the program runs only up to the moment when the first form should show up. I can see the progress to the form from "WAIT... WINDOW" traces put into the starting prg. Once the form should be opened, there is nothing at all. There are no traces of anything related to the program or FoxPro in general in the Task Manager either.

If I start it manually from the FoxPro 6.0 window by running the starting prg (declarations, initializations, etc. all the way to showing the first form), everything works fine, too, and I have a perfectly working application.

If I build not an exe, but just an app and run it, the first form does show up, but its grids that should show data from linked tables are not populated.

Again, this is a problem only of one computer.

Any ideas what may be the problem?

Thank you.
VitalyNagyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pcelbaCommented:
The short answer: If the error appears on ONE computer only then reinstall OS on this one computer.

If you are dummy then you may investigate your app behavior in more details, e.g.:
Download Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx) which should tell what the app is doing and why it "disappears". It can be anything, e.g. some improperly installed OCX control, VFP run-time, C run-time, virus, etc.

BTW, isn't VFP 6 a little bit obsolete? I would rather use VFP 9 on Windows 7. (I know even VFP 9 becomes obsolete but new add-ons and applications are still under development and unofficial patches are released.)

What SP do you have installed for VFP 6?
0
VitalyNagyAuthor Commented:
It is SP2. I tried to buy VFP 9, but could not find one.
0
pcelbaCommented:
So, first of all you should upgrade to VFP 6 SP5 (look for VS6 SP5).

VFP 9 is still available as OLP version: http://www.cdw.com/shop/products/Microsoft-Visual-FoxPro-Professional-Edition-v.-9.0-license/748846.aspx
VFP 9 is available as boxed product: http://shop.dfpug.de/productslist.aspx?CategoryID=17&selection=3
and VFP 9 is also a part of MSDN Professional subscription.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.