Solved

DLINK DNS 343 - Possible bad enclosure or drives or array

Posted on 2014-09-06
5
190 Views
Last Modified: 2015-07-23
Hello,

I am working with a brand new client. The client has 2x DNS 343 enclosures. We will call them 127 and 49 based on their IP addresses. 127 was the main drive, and it was supposed to be mirroring to 49 on a regular basis. It wasn’t. 127 and 49 both had 4x 2TB Samsung HD204UI disks in a RAID 5 array.

Users began noticing data missing or corrupted. The drive holds approximately 3TB of data normally. A check indicated less than 2TB visible in Windows Explorer. This decreased over the next hour to 165GB when I first checked it on scene.

I shut down the DNS 343, let it rest and then started it back up. All data was visible and accessible. I checked the drives using the web administration Disk Diagnostic interface. All passed. I went home for the evening.

The next morning, data was again missing, etc. I came back over and observed the same behavior of a shrinking amount of data. Temperatures in the web interface read at 90-100 degrees. After reviewing the boards and consulting with a partner, we determined the following course of action (DLink tech support wanted us to update the firmware first, but I was leery to do so, because in my experience that can cause its own problems).

First, I suspected a bad/wonky drive. I powered down the machine, removed and labeled disk 1 and tried to boot. No data. I then powered off, removed and labeled disk 2 and tried again. No data – and so on until I removed drive 4. With drive 4 gone, drives 1-3 functioned well. All data was visible and the response seemed snappy. As a side note, SMART testing had not detected any issues with drive 4.

Users had been instructed to make a list of prioritized data they needed. We immediately began to offload data onto a backup. About 90 minutes later, the data started to act funny again. The owner noted the fans on the DNS 343 were not spinning. I powered off the machine. Then we powered it on again, saw the data, and took a last few emergency files off. I then backed up the settings.

At this point, I went and bought three WD 2TB hard drives and cloned them over using two dual bay external docking ports with a direct clone function. After that was done, I went to the other DNS 343 enclosure (49), where the last backup was ~1 yr old. I backed up the data, powered down, removed the drives, factory reset, updated the firmware on this known good machine. I then restarted and uploaded the settings from the other enclosure. I then powered down, inserted the numbered Samsung drives in the correct order and voila! Everything looked good.

We then began pulling data off and I went home again. Checking remotely two hours later, the data was wonky again and copy operations could not continue (unable to access file on network and invalid copy handle errors). I am now back over at the office. Of my three ‘good’ drives , two are reading failed in disk diagnostic (Note: HD Tune Pro quick scans show no bad sectors). As a side note, the fans on my known good enclosure were not spinning when I arrived.

I am currently assembling all the data I was able to get off three attempts into an aggregate. I believe I have 60% of mission critical data. I hate RAID 5. I am a RAID 1 guy all the way.

Additional Notes:
1.      Each of the RAID 5 drives when placed individually into an enclosure and read with ext2read show a /dev/sdc4 partition with what looks like the array info? They do not show any other data. A RAID 1 disk in ext2 formatting shows /dev/sdc4 with similar files and a separate /dev/sdc2 section with all the data (this was just a test disk, since I am not familiar with ext2reader).
2.      Should the fans not be spinning all the time?
3.      Why did this go bad in the other enclosure which had been working just fine before factory reset and introduction of these drives?
4.      Most importantly, what should I do now? Thoughts?

I am unfamiliar with RAID 5 in a NAS of this type. I am interested in step by step instructions for items as easy as how to rebuild the array if recommended (I had been pursuing backing up before rebuilding).

Thank you in advance for your expertise.

Best Regards,
panda
0
Comment
Question by:pandafusion
  • 3
  • 2
5 Comments
 
LVL 42

Expert Comment

by:Davis McCarn
Comment Utility
Those Samsung drives have a serious bug in their firmware which can cause data loss: http://knowledge.seagate.com/articles/en_US/FAQ/223571en

As for the fan issue, check the temps if you see they are not spinning.  The fans might not need to be on if the NAS is still under 100F.
0
 

Author Comment

by:pandafusion
Comment Utility
Thank you for the info on the Samsung drives.
Temperatures have not been observed above 103 and are typically 90-100. Based on further review, it appears the fans should not always be spinning.

I factory reset the original machine and reloaded settings. I installed 3 drives (installing the 4th makes the RAID 5 array undetectable on the network). I have been pulling prioritized data off for 2.5 hours now, with ~1.5TB total data remaining.

Given that the error occurred in a second enclosure, I now believe the RAID 5 array information on each disk is corrupted on at least 1 disk.

Still looking for additional solutions and thoughts. I am hoping to crutch along with this until all the data is off. Failing that, I will probably try NAS Data Recovery from Runtime Software, though I have admittedly never used the program before.

ps - nice bio and thank you for the response :)
0
 
LVL 42

Expert Comment

by:Davis McCarn
Comment Utility
Runtime's software is excellent!  I have been using GetDataBack since about 2002 and it, in general, outperforms everything else.
0
 

Accepted Solution

by:
pandafusion earned 0 total points
Comment Utility
Apologies, i apparently did not notice this was open :)
I was able to limp through getting most of the critical data off the array. We unsuccessfully tried a couple of different software recovery solutions before sending the drives out for lab recovery.

As an FYI and referral for a company in which I have no commercial interest whatsoever, we used $300 data recovery in California. they were able to recover all of our data and get our new disk back to us very quickly (about 4TB in 3 days total turn time including shipping after we selected all expedited options available). I was initially very skeptical of their numerous positive reviews and lack of negative reviews. However, they were inexpensive and professional.
0
 

Author Closing Comment

by:pandafusion
Comment Utility
Only two comments submitted by a single expert. While appreciated, the comments submitted did not solve the issue at hand in this case.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Possible ways to recover from drive crash 29 63
Synology NAS used as External Hard drive 6 51
HP Z440 RAID 1 43
Nic to NIC 5 43
In this article you will get to know about pros and cons of storage drives HDD, SSD and SSHD.
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now