SBS2008 IMAP intermittent - Thunderbird - The connection was refused

SBS2008 Server
20 x client on LAN with Thunderbird (lets not discuss this choice) connecting to the Exchange server via IMAP (STARTTLS)

One of the workstations has a issue were several times a day thunderbird report 'The connection was refused'.   Restarting the workstation sometimes solves this.

The event logs on the workstation do not show anything related.
The event logs on the server do not show anything related.

Any ideas?
I don't have much experience with IMAP on Exchange - Maybe there is some tweak to make it work 'correct' ?

Thanks
-Paul
LVL 1
Chief AvocadoChief of Problem Avocado'sAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

suriyaehnopCommented:
1 out of 20 having the issue,right? Do you try to create for this user to user IMAP on other machine?
0
Simon Butler (Sembee)ConsultantCommented:
Most problems with IMAP on Exchange are outside of Exchange. They are usually client related.

Have you got logging enabled on the IMAP server? It isn't enabled by default. That may give you some more information.

Not really much you can do with IMAP configuration wise, it either works or it doesn't in my experience.

Simon.
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Ok, let add some more details.  This is new client to me with a setup they have self-managed for a some years, some bits are ok, some setup is ugly.

5 machines were having this issue last week and it seems to be related to an AVG update that requested the machines to reboot.   After the reboot these machines had an issue.   A further two of three reboots seemed to clear the issue.   Since then, AVG has been removed and a bitdefender powered AV has been installed (something I can support).

So 4 machines cured, but this 1 machine still has issues.  AVG removed, still issues.
As a work around I have found a license for Office 2003 in there collection of discs anf have installed Outlook 2003.   This worked first time, but not perfect as old mail and contacts still in Thunderbird.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Let me also add, that one a second workstation is now reporting 'connection refused' when using with Thunderbird/IMAP/STARTTLS

Can you advise how to switch on IMAP logging on the server?
0
Simon Butler (Sembee)ConsultantCommented:
EMS commands.
This is the TechNet article that explains how.
http://technet.microsoft.com/en-gb/library/aa997690(v=exchg.150).aspx
It is for Exchange 2010, but the commands are the same for 2007.

Be wary of the paths involved, as the logs could get quite large if you are using IMAP a lot.

Mail and Contacts should be in the mailbox, so seen by Outlook 2003. Check the mailbox through OWA to ensure the content is there. If it isn't, then the old client is removing the content, which rather defeats the point of using IMAP.

Simon.
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Thanks fo rthe reply.  I did find that docuemnt, but the command will not accept '-ProtocolLogEnabled'

I can get the status tho:

[PS] C:\Windows\System32>Get-ImapSettings | fl


ProtocolName                      : IMAP4
Name                              : 1
MaxCommandSize                    : 10240
ShowHiddenFoldersEnabled          : False
UnencryptedOrTLSBindings          : {:::143, 0.0.0.0:143}
SSLBindings                       : {:::993, 0.0.0.0:993}
X509CertificateName               : remote.[redacted.name]
Banner                            : The Microsoft Exchange IMAP4 service is rea
                                    dy.
LoginType                         : SecureLogin
AuthenticatedConnectionTimeout    : 00:30:00
PreAuthenticatedConnectionTimeout : 00:01:00
MaxConnections                    : 2000
MaxConnectionFromSingleIP         : 2000
MaxConnectionsPerUser             : 64
MessageRetrievalMimeFormat        : BestBodyFormat
ProxyTargetPort                   : 143
CalendarItemRetrievalOption       : iCalendar
OwaServerUrl                      :
EnableExactRFC822Size             : False
AdminDisplayName                  :
ExchangeVersion                   : 0.1 (8.0.535.0)
DistinguishedName                 : CN=1,CN=IMAP4,CN=Protocols,CN=SERVER,CN=Ser
                                    vers,CN=Exchange Administrative Group (FYDI
                                    BOHF23SPDLT),CN=Administrative Groups,CN=Fi
                                    rst Organization,CN=Microsoft Exchange,CN=S
                                    ervices,CN=Configuration,DC=[redacted],DC=loca
                                    l
Identity                          : SERVER\1
Guid                              : 8d655287-a4aa-45ab-94ac-9f4aa274044e
ObjectCategory                    : [redacted].local/Configuration/Schema/ms-Exch-
                                    Protocol-Cfg-IMAP-Server
ObjectClass                       : {top, protocolCfg, protocolCfgIMAP, protoco
                                    lCfgIMAPServer}
WhenChanged                       : 08/09/2014 11:01:07
WhenCreated                       : 04/11/2009 12:07:57
OriginatingServer                 : SERVER.[redacted].local
IsValid                           : True
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
[PS] C:\Windows\System32>Set-ImapSettings -server "server" -ProtocolLogEnabled $true

Set-ImapSettings : A parameter cannot be found that matches parameter name 'Pro
tocolLogEnabled'.
At line:1 char:54
+ Set-ImapSettings -server "server" -ProtocolLogEnabled  <<<< $true
0
Simon Butler (Sembee)ConsultantCommented:
I don't do much with IMAP so was sure the commands are the same. A quick check on my lab 2007 server shows it is not, it is XML files.

in C:\Program Files\Microsoft\Exchange Server\ClientAccess\PopImap

open the file Microsoft.Exchange.IMAP4.exe.config in a text editor.
Near the bottom is the line:
<add key="ProtocolLog" value="false" />

Change it to True.
You can also change the path of the log here as well if you wish.
Save the file, then restart the IMAP service.

Don't forget to disable the log by changing it back to false when you are done.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Good find - thanks
I assume the IMAP service will need restarting?
0
Simon Butler (Sembee)ConsultantCommented:
That is what I said. :-)
"Save the file, then restart the IMAP service. "

Simon.
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Duh!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.