Solved

SBS2008 Lost OWA and RRW since installing SSL CERT

Posted on 2014-09-08
11
32 Views
Last Modified: 2015-06-21
SBS2008 was using a self signed cert.
I have installed a Cert from Godaddy (done this before on many times), but now only the default IIS page is show the the url like this

https://the.server.address/owa/

gives a 404 error

How can this be corrected?

Thanks
-Paul
0
Comment
Question by:pc-cyt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 19

Expert Comment

by:Kash
ID: 40309498
have you attached the services to the certificate in exchange
0
 
LVL 1

Author Comment

by:pc-cyt
ID: 40309506
If I run Get-ExchangeCertificate and crosscheck the thumbprint, then I see the services enabled are I..WS
Which I think is IMAP/WEB(IIS)/SMTP ?
0
 
LVL 19

Expert Comment

by:Kash
ID: 40309660
go to exchange management console and then click on Server Configuration. On the left tab you will see  Exchange Certificate, select the certificate you have installed and assign services to it.

It will also tell you what services are currently attached to it.

also, have you pointed the URLs for internal and external accordingly.

In server configuration, click on Client Access and then in Outlook Web App, right click on owa(default) and check internal / external website on it

it may be worth soft restarting the default IIS website.

Can you access owa internally ?
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
LVL 1

Author Comment

by:pc-cyt
ID: 40309715
Attached screenshot - I cannot find the option you talk about for assigning services

URLS should be OK as this was working before with teh self-signed cert.  Revieweing the settings now they seem OK.   https://remote.[domain.name]/owa/

The server was restarted after the Cert was installed.

OWA is not accessible from internal (it was before) - Screenshot attached
002611.png
002612.png
0
 
LVL 1

Author Comment

by:pc-cyt
ID: 40310795
Rebooted server, but still the same.
0
 
LVL 19

Expert Comment

by:Kash
ID: 40311474
have a look at the screenshots attached. You should have the options as I have.

apart from installing certificate, did you change any other settings?
screen1.png
screen2.png
0
 
LVL 1

Author Comment

by:pc-cyt
ID: 40311496
I think the trouble is, your are using SBS2011?  or something with Exchange 2010.
I have SBS2008/Exchange 2007

The lower pane with the certificate status is not shown on  the version here.
0
 
LVL 19

Expert Comment

by:Kash
ID: 40311819
follow this article here to check the certificate and assign services to it >>> https://support.globalsign.com/customer/portal/articles/1226878-install-certificate---microsoft-exchange-2007
0
 
LVL 1

Accepted Solution

by:
pc-cyt earned 0 total points
ID: 40314722
Fixed!

The 'Default' site was started, which blocked the SBS Applications from starting (same port).
Stopped the default site, set to not auto start
Then Start the SBS Applications.

OWA and RWW now working as expected.
0
 
LVL 19

Expert Comment

by:Kash
ID: 40314727
glad you fixed it. also, you could look in to changing ports for default website from 80 to something else
0
 
LVL 1

Author Closing Comment

by:pc-cyt
ID: 40841888
Because it worked
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this step by step procedure, you will come to know the details of creating an Outlook meeting in 2007, 2010, 2013 & 2016.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question