SBS2008 Lost OWA and RRW since installing SSL CERT

SBS2008 was using a self signed cert.
I have installed a Cert from Godaddy (done this before on many times), but now only the default IIS page is show the the url like this

https://the.server.address/owa/

gives a 404 error

How can this be corrected?

Thanks
-Paul
LVL 1
Chief AvocadoChief of Problem Avocado'sAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kash2nd Line EngineerCommented:
have you attached the services to the certificate in exchange
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
If I run Get-ExchangeCertificate and crosscheck the thumbprint, then I see the services enabled are I..WS
Which I think is IMAP/WEB(IIS)/SMTP ?
0
Kash2nd Line EngineerCommented:
go to exchange management console and then click on Server Configuration. On the left tab you will see  Exchange Certificate, select the certificate you have installed and assign services to it.

It will also tell you what services are currently attached to it.

also, have you pointed the URLs for internal and external accordingly.

In server configuration, click on Client Access and then in Outlook Web App, right click on owa(default) and check internal / external website on it

it may be worth soft restarting the default IIS website.

Can you access owa internally ?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Attached screenshot - I cannot find the option you talk about for assigning services

URLS should be OK as this was working before with teh self-signed cert.  Revieweing the settings now they seem OK.   https://remote.[domain.name]/owa/

The server was restarted after the Cert was installed.

OWA is not accessible from internal (it was before) - Screenshot attached
002611.png
002612.png
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Rebooted server, but still the same.
0
Kash2nd Line EngineerCommented:
have a look at the screenshots attached. You should have the options as I have.

apart from installing certificate, did you change any other settings?
screen1.png
screen2.png
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
I think the trouble is, your are using SBS2011?  or something with Exchange 2010.
I have SBS2008/Exchange 2007

The lower pane with the certificate status is not shown on  the version here.
0
Kash2nd Line EngineerCommented:
follow this article here to check the certificate and assign services to it >>> https://support.globalsign.com/customer/portal/articles/1226878-install-certificate---microsoft-exchange-2007
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Fixed!

The 'Default' site was started, which blocked the SBS Applications from starting (same port).
Stopped the default site, set to not auto start
Then Start the SBS Applications.

OWA and RWW now working as expected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kash2nd Line EngineerCommented:
glad you fixed it. also, you could look in to changing ports for default website from 80 to something else
0
Chief AvocadoChief of Problem Avocado'sAuthor Commented:
Because it worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.