Using an FXS card for Fax on cisco 2821 Router - H.323 Gateway

I will be activating a PRI in the coming days.  My fax number will be ported into the PRI.  How do i configure the FXS ports to allow for inbound and outbound fax?  I looked at many links from Cisco, but am still unsure.  Can someone send me an example of a configuration they have used that works?  I'm using CUCM 7.1.5, just an FYI.  I will attached my configurations.  

My call routing plan is as follows:

Any calls in the 610 range, 866 range and 888, range are the main numbers to the office which get routed to the auto attendant via 2001 (CTI Route Point)

My fax is 610-xxx-xxxx

All calls in the 484 range are for DID.
PRI-Router.txt
LVL 4
denver218Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

agonza07Commented:
Several ways of doing it, but looks like you are already doing H323 so lets stick with that.

Let's say your fax number is 610-555-1234 and its on port 0/1/0

1) You'll need to adjust your translation pattern, so it doesnt get sent to your CUCM.
voice translation-rule 2
 rule 1 /6105551234/ /1234/
 rule 2 /610......./ /2001/

2) Configure the voice-port
voice-port 0/1/0
description ** Fax Machine **
station-id name Fax_Machine
station-id number 1234
caller-id enable

3) Define your fax dial-peer
dial-peer voice 1234 pots
desc ** To Fax Machine **
 destination-pattern 1234
 port 0/1/0

With this I think inbound to the fax machine should work. It doesnt look like you have any outbound dial-peers on the gateway, so I'll leave that out for now.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
denver218Author Commented:
Thanks that worked perfectly!
0
denver218Author Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for denver218's comment #a40333216

for the following reason:

Thanks that worked perfect.  I just had to add an outbound dial peer as you alluded to.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

denver218Author Commented:
Worked perfectly.  Thanks!
0
Nitesh PoudelCommented:
I have a same problem. I am using CUCME with FXS port for Fax and T1 PRI for incoming calls.
I don't have any gateways and CUCM. Any suggestions on how to configure?
1
agonza07Commented:
Please open a new question and upload a sanitized config. This question is closed and no longer monitored.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.