Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 40
  • Last Modified:

exchange emails being delayed

I have a problem where emails from my server are failing or being delayed, we are running exchange 2010, i'm not sure what the issue is, internal emails are fine and we are receiving ok.
I have run best practice and exchange mail flow trouble-shooter but still cannot find the issue?? I'm not sure what else I need to try??
0
pcspcs2011
Asked:
pcspcs2011
  • 3
  • 2
1 Solution
 
tshearonCommented:
Have you checked your Exchange Queues and seen the emails backing up? If so, what was the last error information? Do you use a smarthost or are you sending directly to the internet for delivery? If a smarthost, can you connect to the address using telnet over port 25. If you can do that what happens when you issue a helo command? You should be receiving something in your event logs. Can you share that as well?
0
 
tshearonCommented:
Also, check that your logs and mail data directories as well as your Hub transport server all have plenty of disk space. Low to no space can trigger back pressure and cause delivery failures/delays.
0
 
pcspcs2011Author Commented:
have checked exchange que and I am getting this message  451.4.4.0 DNS Query failed??

not sure where to go from here?
0
 
tshearonCommented:
So how does mail leaving your organization work? Do you send it to an appliance (SmartHost) or directly to the internet using MX records? You can find this by looking at your send connectors on your hub transports. If it is straight to the internet check the validity of your DNS settings and make sure your Exchange machine can get to the internet. If it is a smarthost make sure you can still get to the smarthost with telnet as I suggested earlier. Also, please let me know what you have done to try and resolve the issue so we are not repeating steps. Have you rebooted, restarted the DNS service, etc?
0
 
pcspcs2011Author Commented:
I have fixed the issue, someone in had installed some anti-malware software on the server, as soon as it was removed emails worked normally
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now