Solved

Shortel and Cisco switch configuration

Posted on 2014-09-08
9
750 Views
Last Modified: 2014-09-29
Hello all,

I have looked at some of these posts, but none really address what I am trying to do.

Several sites on seperate subnets on default native vlan

192.168.102.x
192.168.103.x
192.168.104.x

S/M 255.255.255.0

Voice vlan ip as follows:

10.10.102.x
10.10.103.x
10.10.104.x

S/N 255.255.255.0

All default gateways are

x.x.x.1

We are putting in Shoretel system and are having trouble getting the vlans set up

All switches are Cisco 2950 and 2960 switches.

I have vlan 1 for the 192.168.x.x with subnet of 255.255.255.0
I have voice vlan for the 10.10.x.x with subnet of 255.255.255.0

The switches currently have the following commands on the ports:
switchport mode access
switchport voice vlan 5
no cdp enable
spanning-tree portfast

The port that will have the Shoregear switch plugged into it is configured as such:
description Uplink to Shoretel Switch
switchport trunk native vlan 5
no cdp enable
spanning-tree portfast

Uplink ports are:
switchport mode trunk


Now, the issue that I have at the moment is that most switches when issuing the no shut command on voice vlan 5, it will shut down vlan 1 (default native) and I lose remote access on the switch. What is wrong with the config? All ports need to be configured so that a PC and phone can be plugged into it. Also, the Shoretel server that will use both vlans as well.

Note...there will be no DHCP or auto config needed as the phones will be manually programmed.
0
Comment
Question by:compunet1
  • 4
  • 4
9 Comments
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 40311532
To see what is wrong with the configuration, please post switch configuration without passwords, secrets, or other sensitive information. I believe you need to enable lldp globally for the switch to recognize your phones as phones so they can get the voice vlan.
0
 
LVL 15

Expert Comment

by:getzjd
ID: 40311814
I agree, we need the full config, but some suggestions:

Our switch port configs are basic (we use adtran but the ios is almost identical to cisco)

Here is a default access port

interface switchport 0/1
  no shutdown
  switchport mode trunk
  qos trust cos

This would be an uplink to a shoregear switch

interface switchport 0/17
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
  switchport voice vlan 5
  qos trust cos

Manually programming the phones seems a bit tedious as well.   I would recommend that you set option 156 in DHCP   option 156 ascii "ftpservers=<IPOFYOURSHORETELFTP>, country=1, language=1, layer2tagging=1, vlanid=5"

Our ShoreTel server sits on the standard data vlan 1
0
 

Author Comment

by:compunet1
ID: 40312733
The sites switch configs are pretty basic. I am not the one setting up the phones or Shoretel server. I am just facilitating the network config.

I have attached two switch sites. All ports are configured identically. (I cut out identical ports)

The goal is this:

Data vlan = vlan1

Voice = Vlan5

Keeping all Shoretel from touching data vlan, including server. The PC and phones will be daisy chained.

I don't have access to the routers, just the switches. I want to keep this as simple as possible. Problem I have is that vlan 5 is shutdown on the central site and when I run no shut on vlan5 , it shutsdown vlan1. I still have connectivity to the sites, but lose connectivity to the switches. What could be causing this as the remote site listed doesn't do this and I have never witnessed that type of behavior from a Cisco switch.

Central site:Central-Site.txt

Remote Site: Remote-site.txt
0
 
LVL 42

Accepted Solution

by:
kevinhsieh earned 500 total points
ID: 40313113
These commands and configuration commands apply to both switches. I assume that you have another device doing routing between the two VLANs.

conf t
! switch to rapid spanning-tree mode
spanning-tree mode rapid-pvst
! enables LLDP so your phones will tell the switch that they are phones
lldp run
! you don't need a  L2 interface, not a L3 vlan interface
no int vlan 5
! creates L2 vlan interface if it doesn't already exist
! if the L2 VLAN already exists this won't change anything
vlan 5

! I suggest converting access to SSH only and remove telnet
! generate RSA keys
crypto key generate rsa modulus 4096

! passwords on VTY are a security risk. You should be logging in with a username instead
! if you need to add a username,
!# username myname priv 15 secret 0 myplaintextpassphrase
line vty 0 4
 no password
 transport input ssh
 login
line vty 5 15
 no  password 
 transport input ssh
 login

! I suggest you turn off management via http, and switch to https
no ip http server
ip http secure-server

Open in new window

0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 

Author Comment

by:compunet1
ID: 40316580
Kevin,

That is correct, the routers are handling the vlan routing.

So, i need to create a L2 interface or L3???

Also, enable lldp on all ports?
0
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 40316615
Just turn on lldp globally. Your switches need to have L2 VLANs created. Creating an additional L3 interface on an L2 switch isn't useful. I gave you exact syntax for all commands except for creating a username and password, since you should pick those yourself.
0
 

Author Comment

by:compunet1
ID: 40319299
Ok. well. the ios is 12.1(22)
The lldp command doesn't seem to be available. And this is the last ios version available
0
 
LVL 42

Expert Comment

by:kevinhsieh
ID: 40319566
LLDP is available on 2960 switches for sure because I run them. I don't know about 2950. the lldp run is not on an interface, but in the global configuration area.
0
 

Author Comment

by:compunet1
ID: 40326442
Kevin,

I was unable to get LLDP on either the 2950 or 2960 in global config mode.  However, with that said, I did get the issue worked out. The Shoretel switch port had to be put in access mode to work. There is no way to force the Shoretel switch itself to use vlan 5.

The phones come up and are able to communicate with the server and switches on the configured vlan.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
Security is one of the biggest concerns when moving and migrating your data from your on-premise location to the Public Cloud.  Where is your data? Who can access it? Will it be safe from accidental deletion?  All of these questions and more are imp…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now