Shortel and Cisco switch configuration

Hello all,

I have looked at some of these posts, but none really address what I am trying to do.

Several sites on seperate subnets on default native vlan

192.168.102.x
192.168.103.x
192.168.104.x

S/M 255.255.255.0

Voice vlan ip as follows:

10.10.102.x
10.10.103.x
10.10.104.x

S/N 255.255.255.0

All default gateways are

x.x.x.1

We are putting in Shoretel system and are having trouble getting the vlans set up

All switches are Cisco 2950 and 2960 switches.

I have vlan 1 for the 192.168.x.x with subnet of 255.255.255.0
I have voice vlan for the 10.10.x.x with subnet of 255.255.255.0

The switches currently have the following commands on the ports:
switchport mode access
switchport voice vlan 5
no cdp enable
spanning-tree portfast

The port that will have the Shoregear switch plugged into it is configured as such:
description Uplink to Shoretel Switch
switchport trunk native vlan 5
no cdp enable
spanning-tree portfast

Uplink ports are:
switchport mode trunk


Now, the issue that I have at the moment is that most switches when issuing the no shut command on voice vlan 5, it will shut down vlan 1 (default native) and I lose remote access on the switch. What is wrong with the config? All ports need to be configured so that a PC and phone can be plugged into it. Also, the Shoretel server that will use both vlans as well.

Note...there will be no DHCP or auto config needed as the phones will be manually programmed.
compunet1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
To see what is wrong with the configuration, please post switch configuration without passwords, secrets, or other sensitive information. I believe you need to enable lldp globally for the switch to recognize your phones as phones so they can get the voice vlan.
0
getzjdCommented:
I agree, we need the full config, but some suggestions:

Our switch port configs are basic (we use adtran but the ios is almost identical to cisco)

Here is a default access port

interface switchport 0/1
  no shutdown
  switchport mode trunk
  qos trust cos

This would be an uplink to a shoregear switch

interface switchport 0/17
  spanning-tree edgeport
  no shutdown
  switchport mode trunk
  switchport voice vlan 5
  qos trust cos

Manually programming the phones seems a bit tedious as well.   I would recommend that you set option 156 in DHCP   option 156 ascii "ftpservers=<IPOFYOURSHORETELFTP>, country=1, language=1, layer2tagging=1, vlanid=5"

Our ShoreTel server sits on the standard data vlan 1
0
compunet1Author Commented:
The sites switch configs are pretty basic. I am not the one setting up the phones or Shoretel server. I am just facilitating the network config.

I have attached two switch sites. All ports are configured identically. (I cut out identical ports)

The goal is this:

Data vlan = vlan1

Voice = Vlan5

Keeping all Shoretel from touching data vlan, including server. The PC and phones will be daisy chained.

I don't have access to the routers, just the switches. I want to keep this as simple as possible. Problem I have is that vlan 5 is shutdown on the central site and when I run no shut on vlan5 , it shutsdown vlan1. I still have connectivity to the sites, but lose connectivity to the switches. What could be causing this as the remote site listed doesn't do this and I have never witnessed that type of behavior from a Cisco switch.

Central site:Central-Site.txt

Remote Site: Remote-site.txt
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

kevinhsiehCommented:
These commands and configuration commands apply to both switches. I assume that you have another device doing routing between the two VLANs.

conf t
! switch to rapid spanning-tree mode
spanning-tree mode rapid-pvst
! enables LLDP so your phones will tell the switch that they are phones
lldp run
! you don't need a  L2 interface, not a L3 vlan interface
no int vlan 5
! creates L2 vlan interface if it doesn't already exist
! if the L2 VLAN already exists this won't change anything
vlan 5

! I suggest converting access to SSH only and remove telnet
! generate RSA keys
crypto key generate rsa modulus 4096

! passwords on VTY are a security risk. You should be logging in with a username instead
! if you need to add a username,
!# username myname priv 15 secret 0 myplaintextpassphrase
line vty 0 4
 no password
 transport input ssh
 login
line vty 5 15
 no  password 
 transport input ssh
 login

! I suggest you turn off management via http, and switch to https
no ip http server
ip http secure-server

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
compunet1Author Commented:
Kevin,

That is correct, the routers are handling the vlan routing.

So, i need to create a L2 interface or L3???

Also, enable lldp on all ports?
0
kevinhsiehCommented:
Just turn on lldp globally. Your switches need to have L2 VLANs created. Creating an additional L3 interface on an L2 switch isn't useful. I gave you exact syntax for all commands except for creating a username and password, since you should pick those yourself.
0
compunet1Author Commented:
Ok. well. the ios is 12.1(22)
The lldp command doesn't seem to be available. And this is the last ios version available
0
kevinhsiehCommented:
LLDP is available on 2960 switches for sure because I run them. I don't know about 2950. the lldp run is not on an interface, but in the global configuration area.
0
compunet1Author Commented:
Kevin,

I was unable to get LLDP on either the 2950 or 2960 in global config mode.  However, with that said, I did get the issue worked out. The Shoretel switch port had to be put in access mode to work. There is no way to force the Shoretel switch itself to use vlan 5.

The phones come up and are able to communicate with the server and switches on the configured vlan.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.