exchange 2010 calendar permissions for users in different domain

I have a company who hosts their own email using Exchange 2010. They have another company that they host email for. The two companies have a point to point VPN in place. There is a domain trust in place to allow sharing of info.
To allow the users in the trusted domain access to email, I create two accounts for each user, one in each domain. Then I setup the mailbox in domain A and give full access permission to the user account in domain B.
I use powershell for this.
Now, users in domain B want to share calendars with each other. They cannot go into their calendar properties and share it that way because the only users they see are domain A users, obviously.
For full access permission, its easy with powershell because I have the option of using the syntax: domain B\user. The powershell command for setting permissions on individual folders, however, does not give this option. I try to enter the following command and I get "domain A\user is not a valid smtp or there is no matching information..."

Add-MailboxFolderPermission "DOMAIN A\USERX:\Calendar" -User "DOMAIN B\userx" -AccessRights Reviewer

There is only one exchange server, in Domain A. both domains use the same smtp address(i.e. @company.com)

Is there any way to add calendar permissions to users in a different, trusted domain?
LVL 1
ilguybobAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
You can only add mail enabled users to the permissions list. Therefore the only way that will work is to add the mailbox of the user to the list of permissions, not the AD account.

Simon.
0
ilguybobAuthor Commented:
The users in domain B do not have an exchange server, so they have no mailboxes. So let's say i have a new user starting in domain B. I setup a user account and mailbox for them in domain A and give permissions to the account I setup for them to log in with in domain B.
I have been using this command to give full access and it works fine:
Add-MailboxPermission "Domain A user mailbox" -User "Domain B\user" -AccessRights FullAccess

I just can't find out how to give permission only to the calendar.
Or, is there an easier/better way to setup mailboxes in this scenario?
0
Simon Butler (Sembee)ConsultantCommented:
I understood that.
The users still have mail enabled accounts - just in the same domain as the Exchange server. It is that account that have to add to the permissions.

The Add-MailboxPermission you are doing is AD permission, folder permissions are mailbox permission.

Simon.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

ilguybobAuthor Commented:
Aha, I see. So there is really no way to do what I am trying to do without giving full access permission to the whole mailbox? Or, I am not understanding what you mean.
I want to share domain B users calendars with other domain B users.
0
Simon Butler (Sembee)ConsultantCommented:
You cannot grant permissions at the AD level without granting full mailbox.
However if the users have a mailbox then just add their mailbox to the list of permissions - that should work.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ilguybobAuthor Commented:
Actually, I could not get the permissions to work unless I gave full access, which was not desired.
I ended up changing the permission to reviewer for "default", which accomplished what I wanted.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.