Enabled Legacy support in Storefront 2.0 version, and what other setting to ensure pass thru authentication?

Hello there,

We have enabled Legacy support in Storefront 2.0 version, and what other setting to ensure pass thru authentication? so that users wont get Citrix Receiver logon prompt, each time they login.

Please advise.

Thanks and regards
goprasadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhandelsCommented:
So you want users to login with their domain accounts on a StoreFront server and they only need to type in their password just once??

If so, make sure to go to the StoreFront server then right click on the Authentication option and choose Add/Remove Methods. The thing to select is "Domain pass-through".. This should do the trick.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
goprasadAuthor Commented:
I did go to the StoreFront server then right clicked on the Authentication option and choose Add/Remove Methods, and selected  "Domain pass-through"
But even after that, when Citrix Receiver is prompting to enter logon credentials, not sure why?
0
rhandelsCommented:
Do you mean the webinterface or the local client on the machine? How are you connecting to the StoreFront server?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

goprasadAuthor Commented:
Via Citrix Receiver 3.2 on client machine.
0
rhandelsCommented:
So your not using the StoreFront webinterface i guess? You added the correct service address into the client? If you type in password and username do you get to see the correct apps in the startmenu??

Here is a good link on how to configure passthrough authentication for the client version.

http://support.citrix.com/article/CTX133855
0
artisancomputer_msmCommented:
I assume that since you are using Storefront that you are not using PNAgent.  If that's correct, then when installing receiver, use this command:  

CitrixReceiver.exe /includeSSON ADDLOCAL="ReceiverInside,ICA_Client,SSON,USB,DesktopViewer,Flash" ENABLE_SSON=Yes SERVER_LOCATION="web interface location goes here"

Open in new window


This makes sure the Receiver is configured with Passthrough components enabled.

Then you want to make sure the local policy is in place to enable passthrough authentication on the client.  If you don't have a mixed environment with multiple versions of ICA client and Receiver you can use the Citrix ICA Client ADM Template and create a group policy that enables passthrough authentication on the client.

Or, you could slam this Reg file onto the client machine which does the same thing:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix]
"EnableFTU"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Logon]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Logon\Local Credentials]
"SSOnUserSetting"="true,false"
"EnableSSOnThruICAFile"="true"
"UseLocalUserAndPassword"="true,false"
"LegacyLocalUserNameAndPassword"="true"
"SSOnCredentialType"="Any,NT,NDS"

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\SSON]
"Enable"="true"

Open in new window

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.