Using ftp server transfers router ios to ftp server

Hi Expert

I have a problem when I try totransfer a router’s ios to ftp server. I got the following info. I set upusername and password in the cisco router, which are same with username andpassword in ftp server(FileZilla). The router interface ip address is ftp server ip address is PC). The router and PC can ping each other. After I used copy command, I goterror message --- Incorrect Login/Password. Any expert can give me somesuggestion ? Thank you.

Abc#ip ftp username cisco
Abc#ip ftp password cisco
Abc#copy flash: ftp
Source filename [c2900-universalk9-mz.SPA.bin]?
Address or name of remote host[]?
Destination filename [c2900-universalk9-mz.SPA.bin]?
Writing c2900-universalk9-mz.SPA.bin
%Error opening Login/Password)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Can you use another ftp client or browser and browse to the ftp server and login?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pete LongTechnical ConsultantCommented:
Why not simply use TFTP?

Then issue a copy flash tftp command and follow the prompts?

Craig BeckCommented:
Use the URL like this...

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

EESkyAuthor Commented:
@Administrator-----eenookami, That was is because EE website always told me that i was not successful to submit my reply and gave me an error message after i submitted
Joshua GrantomSenior Systems AdministratorCommented:
you must configure the default ftp username and password.

run config t , then run these lines. be sure to change the italic username and password with the correct user and password.

ip ftp password password
ip ftp username username

then you should be able to run copy flash
EESkyAuthor Commented:
@dmwynne, you are right. I can not login when i browse with Google browser, which means the password and username are incorrect. But I reset the username and password in the server, why is the problem still there ? I tried several different username, but it still does work. The default username is admin ? Thank you.
EESkyAuthor Commented:
I did it exactly based on your link. But it still cannot work. Do you think it is Macfee problem, which is installed in my PC? But ping is not problem. The port 21 is also open. This FileZilla is second ftp server software that I am trying. The previous one has the same issue with this.
Joshua GrantomSenior Systems AdministratorCommented:
I would disable McAfee temporarily while you try this.
To verify the port is open from another machine telnet 21 or use putty, if it lets you connect you know it open if not it could be your firewall.

When you tried with the browser did you get the username / password prompt?
EESkyAuthor Commented:
Thank all of you. All that you said are right. The PC is in the domain system. After giving authentication, It started to work out. Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.