Solved

ASP Page not rendering on IIS7 on windows server 2008

Posted on 2014-09-10
8
490 Views
Last Modified: 2014-11-01
Hi I have shifted my website to windows 2008,there I am using IIS7.My all code working there except .asp page.I am attaching screenshot,please have a look and let me know how to fix this.
0
Comment
Question by:Sudhanshum
8 Comments
 

Author Comment

by:Sudhanshum
ID: 40314182
Here is attachment.Asp Page error
0
 
LVL 19

Expert Comment

by:Rikin Shah
ID: 40314190
0
 
LVL 52

Expert Comment

by:Scott Fell, EE MVE
ID: 40314192
You need to turn on asp

Click Start, point to Administrative Tools, and then click Server Manager.

In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS).

In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role Services.
On the Select Role Services page of the Add Role Services Wizard, select ASP.

http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 

Author Comment

by:Sudhanshum
ID: 40314231
I checked your link and gone same place But i found it seems added,See attached image.ASP
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 40314311
NET Framework 4.0 is installed it is not "Enabled" by default in IIS 7, you have to "allow" it in IIS 7 manager, click on your server name, not the website that is not displaying the page, in my case the ISAPI and CGI Restriction icon only appears there. Open up ISAP and CGI restrictions and enable both entries for .NET Framework 4.0.
http://forums.iis.net/t/1190786.aspx?Error+404+2+ISAPI+and+CGI+list+settings+restrictions+list+settings+on+Web+Server
0
 
LVL 6

Accepted Solution

by:
worthyking1 earned 500 total points
ID: 40317752
You need to make sure that you have BOTH of the following enabled for Classic ASP (since I assume that is what you are trying to run with a .asp page):

1. ISAPI and CGI Restrictions
2. Handler Mappings

You can enable these at the parent (global) level by clicking on the host name at the very top of your sites tree in IIS, or (for #2 only) enable them for each individual site. If enabling at the parent level make sure you push the same settings to all child sites.

To set each one do the following:

ISAPI and CGI Restrictions
1. Click on host name in IIS tree
2. Scroll to IIS section of main view window and click on "ISAPI and CGI Restrictions"
3. Make sure ASP is there and enabled. If not then click "Add".
4. Enter path to executable: C:\Windows\system32\inetsrv\asp.dll for 64-bit DLL, or C:\Windows\SysWOW64\inetsrv\asp.dll for 32-bit DLL. I would use 64-bit unless you have specific reasons for needing 32-bit support.
5. Enter a name, such as "Active Server Pages"
6. Check the box to allow path execution.

Handler Mappings
1. Click on host name in IIS tree (or individual site)
2. Scroll to IIS section of main view window and click on "Handler Mappings"
3. Make sure support for .asp pages is there and enabled. If not then click "Add Script".
4. Fill out the dialog box, as follows:
RequestPath: *.asp
Executable: C:\Windows\System32\inetsrv\asp.dll (or use the 32-bit dll as mentioned above)
Name: ASPClassic (this can be anything you want)

To propagate the global settings to child sites just click on the site > Handler Mappings > Revert to inherited

Also, if you plan on using ASP pages for you homepage then make sure to add index.asp or default.asp etc. to your Default Document setting for the relevant site. In IIS click on site > IIS > Defaul Document

That should solve your problem.
0
 
LVL 32

Expert Comment

by:Big Monty
ID: 40416969
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
Problem Hi all,    While many today have fast Internet connection, there are many still who do not, or are connecting through devices with a slower connect, so light web pages and fast load times are still popular.    If your ASP.NET page …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now