How to block emails from specific external email address?

Hi There,
I have been asked to block emails coming to our Exchange 2013 SP1 server from outside our organizations from specific email address. In my case here I’m using ‘annoying-dude@gmail.com’ as an example.
In Exchange Admin center (EAC) I have created new mail flow rule with following conditions:
===
Block email from ‘annoying-dude@gmail.com’ if the message...Is received from 'Outside the organization' and sender's specified properties match these text patterns: 'Email: annoying-dude@gmail.com'
Do the following...reject the message and include the explanation 'Sender rejected' and Stop processing more rules
===
Well, something is not setup right because we’re still receiving emails from ‘annoying-dude@gmail.com’ Perhaps I’m not digging in the right spot here… Maybe something else needs to be setup?!
Thanks in advance.
LVL 1
OlevoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Two options here.
1. Use a transport rule, but instead use "if header contains" and put in the email address.
2. Install the antispam agents and then configure sender filtering.
http://technet.microsoft.com/en-gb/library/bb124354(v=exchg.150).aspx

The second is built in, so no need to reinvent the wheel with a transport rule.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
netcmhCommented:
Are you sure the email is coming from that address? Could the email just appear to be from that address being spoofed, and is actually something else? Did you check the headers?
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Probably some step is missing.

You can also set up delivery message restrictions.

Both cases are Documented in this link  http://exchangeserverpro.com/block-external-emails-exchange-server-2013-mailbox/

if you still had trouble Enable logging for the transport and check what is happen

What are the CU do you have with SP1?

Let us know.

Regards
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.