"Please specify the product's option(s)" when options have already been selected - problem after Magento 1.8.1 migration

I've migrated a magento 1.8.1 install from one domain to another (separate hosting accounts on the same shared server, so same setup) and haven't changed anything yet, but I get "Please specify the product's option(s)" when trying to add to cart even though the options have already been specified.

I'm pretty sure I didn't miss a step when migrating.
I also tested it with default templates to rule out any template issues.

I will provide links to a product page on the old and new locations when someone answers.

Any ideas?
George AretakisAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
George AretakisConnect With a Mentor Author Commented:
Hi Lucas, Many thanks for your response, but this is now resolved.

It wasn't that problem, mine was cured by adding the ,'false' in this:

<?php echo $this->getSubmitUrl ($_product,'false') ?>
/app/design/frontend/base/default/template/catalog/product/view.phtml

Beats me why it didn't need this on the original site, but does on the new one. The mysteries of magento ...
1
 
Lucas BishopClick TrackerCommented:
Is the entire shopping process, from product-detail page, all the way to the cart, passing over an https connection? Is the product detail page on https, while the add-to-cart passes into a non-https url?
0
 
George AretakisAuthor Commented:
Solved
0
All Courses

From novice to tech pro — start learning today.