Exchange 2013 User Mailbox Issue

I recently migrated from EX2010 to EX2013.  I'm having an issue with a specific users mailbox.  The user can use email from OWA and Outlook on a Windows 7 system, but we also have a terminal server.  On the 2008 R2 terminal server we cannot get Outlook 2010 to connect, it keeps prompting for credentials and states the server is not available.  I can run the Exchange remote connectivity analyzer again any mailbox and it works, except for the one in question.  It give me an error that states:

Testing the address book "Check Name" operation for user USER@domain.com against server 717756d2-f69d-4b8e-82f0-676dbcaaf03c@domain.com.
 An error occurred while attempting to resolve the name.
 
Additional Details
 
The address book Bind operation failed with status -2147467259.
NSPI Status: 2147500037

I've looked and can see the user account in the GAL and can send/receive email from and to the user.  I also checked and the user is NOT hidden from the GAL.  The user can also use a mobile device.  The only difference between the terminal server and the local workstation is using cached Exchange mode.  

I've also removed the user profile from the terminal server and tried several Outlook profiles but get the same result.

Any assistance would be appreciated.
JacksonTechnicalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Paris VicenteSystems and Comunications  Administrator Commented:
That seems to be a resolution names problem in the TS Server.

Can you resolve the FQDN for your Exchange from the TS Server?

The terminal server is in the same AD Site of Exchange?
0
JacksonTechnicalAuthor Commented:
That is what I thought originally, but all the other users can logon to the TS and open Outlook without issues.  I can ping the Exchange server without issue.  I think something specific is wrong with this users mailbox or GAL entry but can't quite put my finger on it.  Its in the same LAN and AD as the Exchange Server and DC.
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Use the Test-email validation from Outlook 2010 and choose the AutoDiscover process and post it here.
If you recreate the profile in Outlook 2010 for that user the problem remains?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JacksonTechnicalAuthor Commented:
I can't get completely through with recreating a profile because it gives and error that the server connection is offline or does not exist.  I can use the Test-email from another user on the terminal server and it works without issue.  It seems to be only if you create a profile using online mode instead of cached Exchange mode with that specific user.  It acts as if the "hide from address list" is selected within Exchange but it isn't.
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Let´s try to check the mailbox for corruption.

Issue this command:
New-MailboxRepairRequest -mailbox MailboxName@mydomain.com  –DetectOnly

SP version in your Exchange?
You also can try to move the mailbox for other mailbox Database and check Again.
0
JacksonTechnicalAuthor Commented:
OK, so I did that command and added -CorruptionType FolderView,AggregateCounts,ProvisionedFolder,FolderView to the command.  It came back succeeded for SearchFolder & AggregateCounts but shows failed on ProvisionedFolder & FolderView.  

Then I did Get-MailboxRepairRequest -Mailbox MailboxName@mydomain.com | FL and got some statistics.  The error code for the failed ones is -2147221246.  How do I know if that really means corruption or not?  All of them list CorruptionDetected 0 in the statistics.
0
JacksonTechnicalAuthor Commented:
Exchange version is 2013 Enterprise (Build 847.32)
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Do you have CAS Array?

NLB?

If you recycle MSExchangeAutoDiscoverAppPool and MS ExchangeRpcProxyAppPool the problem persist?

For recycle go to IIS installed in Exchange 2013 ->Application Pools-> Right Click on top of  MSExchangeAutoDiscoverAppPool -> Recycle

This can take a few minutes to start the new connections to RPC and for AutoDiscover.
If this don´t resolve the issue, try create a throttling  policy  for that mailbox like this:

New-ThrottlingPolicy NoThrottling
Set-ThrottlingPolicy NoThrottling -RCAMaxConcurrency Unlimited -EWSMaxConcurrency Unlimited -EWSMaxSubscriptions Unlimited -CPAMaxConcurrency Unlimited -EwsCutoffBalance Unlimited -EwsMaxBurst Unlimited -EwsRechargeRate Unlimited -DiscoveryMaxConcurrency Unlimited
set-mailbox Username -ThrottlingPolicy NoThrottling

Open in new window


If all this steps fail, make a backup for the old mailbox and recreate the mailbox for that user, then import all the mail´s and folder´s for that new malbox.

Hope it helps.
0
JacksonTechnicalAuthor Commented:
Yes, we are using a DAG.  I've tried restarting the servers and now the AppPool as you suggested.  

What will a throttling policy do?
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Hi Jackson,

Microsoft Exchange Server 2013 message throttling policies set bandwidth limits and restrict the number of processed messages. This is enabled by default on Microsoft Exchange 2013.

Did you try to move the mailbox to another mailbox Database?
0
JacksonTechnicalAuthor Commented:
I'll try moving the mailbox to another database and see what happens.
0
JacksonTechnicalAuthor Commented:
OK, issue has seemed to resolve itself.  I removed my last 2010 server from the network and now the user is not having issues opening Outlook on the terminal server.  I had one last 2010 mailbox server, but it didn't have any databases on it but somehow must have been causing an issue. Thanks for your help.
0
David Paris VicenteSystems and Comunications  Administrator Commented:
Can you explain, if the issue was solved after my last suggestion?

You are welcome, I´m glad to help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ShontieceCommented:
Actually, it happens to be a security issue.  I have the same setup you explained and it turns out it is a security issues in AD that will corrupt the mailbox when moving it.

Steps:
1 go to the persons account in AD
2 go to properties
3 go to the security tab
4 go to advance at the bottom
5 if not check off, check the box that reads "Include inheritable permissions for the objects parent"

Then try moving the mailbox again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.