Solved

Active sync not working

Posted on 2014-09-12
4
314 Views
Last Modified: 2014-11-03
Hi, i am trying to set up active sync on our sbs2003 server. It won't work. I did the connectivity test and got the report below, any ideas how to get it to work. Thanks

The Exchange ActiveSync test failed.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
Elapsed Time: 1217 ms.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Test Steps
 
https://testconnectivity.microsoft.com/Images/Success.png
Attempting to resolve the host name mail.academygroupuk.com in DNS.
 
The host name resolved successfully.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
IP addresses returned: 92.27.135.163
Elapsed Time: 470 ms.
 
https://testconnectivity.microsoft.com/Images/Success.png
Testing TCP port 443 on host mail.academygroupuk.com to ensure it's listening and open.
 
The port was opened successfully.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
Elapsed Time: 284 ms.
 
https://testconnectivity.microsoft.com/Images/Error.png
Testing the SSL certificate to make sure it's valid.
 
The SSL certificate failed one or more certificate validation checks.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
Elapsed Time: 462 ms.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Test Steps
 
https://testconnectivity.microsoft.com/Images/Success.png
The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server mail.academygroupuk.com on port 443.
 
The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
Remote Certificate Subject: CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local, Issuer: CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local.
Elapsed Time: 418 ms.
 
https://testconnectivity.microsoft.com/Images/Success.png
Validating the certificate name.
 
The certificate name was validated successfully.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
Host name mail.academygroupuk.com was found in the Certificate Subject Common name.
Elapsed Time: 0 ms.
 
https://testconnectivity.microsoft.com/Images/Error.png
Validating certificate trust for Windows Mobile devices.
 
Certificate trust validation failed.
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Test Steps
 
https://testconnectivity.microsoft.com/Images/Error.png
The Microsoft Connectivity Analyzer is attempting to build certificate chains for certificate CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local.
 
A certificate chain couldn't be constructed for the certificate.
 
https://testconnectivity.microsoft.com/Images/GreenRtArrow.jpg Tell me more about this issue and how to resolve it
 
https://testconnectivity.microsoft.com/Images/Minus.gif
Additional Details
 
The certificate chain didn't end in a trusted root. Root = CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local
Elapsed Time: 20 ms.
0
Comment
Question by:censura
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40319255
As your certificate is self-issued, you need to run the Activesync test specifying manual settings and make sure you tick the Ignore Trust for SSL check box.

If it doesn't pass the test again, please work your way through my article and shout if you get stuck anywhere.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Alan
0
 

Author Comment

by:censura
ID: 40319270
Hi thank you, i followed your steps when setting this up in the first instance, i ran the test again as suggested and it failed at the en see below


      The Microsoft Connectivity Analyzer is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Additional Details
       
Elapsed Time: 2260 ms.
       
      Test Steps
       
      Attempting to resolve the host name mail.academygroupuk.com in DNS.
       The host name resolved successfully.
       
      Additional Details
       
IP addresses returned: 92.27.135.163
Elapsed Time: 343 ms.
      Testing TCP port 443 on host mail.academygroupuk.com to ensure it's listening and open.
       The port was opened successfully.
       
      Additional Details
       
Elapsed Time: 163 ms.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Additional Details
       
Elapsed Time: 429 ms.
       
      Test Steps
       
      The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server mail.academygroupuk.com on port 443.
       The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.
       
      Additional Details
       
Remote Certificate Subject: CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local, Issuer: CN=mail.academygroupuk.com, CN=companyweb, CN=sbs2003, CN=localhost, CN=sbs2003.academy.local.
Elapsed Time: 403 ms.
      Validating the certificate name.
       The certificate name was validated successfully.
       
      Additional Details
       
Host name mail.academygroupuk.com was found in the Certificate Subject Common name.
Elapsed Time: 0 ms.
      Testing the certificate date to confirm the certificate is valid.
       Date validation passed. The certificate hasn't expired.
       
      Additional Details
       
The certificate is valid. NotBefore = 9/11/2014 3:12:20 PM, NotAfter = 9/11/2019 3:12:20 PM
Elapsed Time: 0 ms.
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
       
Accept/Require Client Certificates isn't configured.
Elapsed Time: 541 ms.
      Testing HTTP Authentication Methods for URL https://mail.academygroupuk.com/Microsoft-Server-ActiveSync/.
       The HTTP authentication methods are correct.
       
      Additional Details
       
The Microsoft Connectivity Analyzer found all expected authentication methods and no disallowed methods. Methods found: Basic
HTTP Response Headers:
MicrosoftOfficeWebServer: 5.0_Pub
Content-Length: 83
Content-Type: text/html
Date: Fri, 12 Sep 2014 13:33:13 GMT
Server: Microsoft-IIS/6.0
WWW-Authenticate: Basic realm="academygropupuk.com"
X-Powered-By: ASP.NET
Elapsed Time: 465 ms.
      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Additional Details
       
Elapsed Time: 316 ms.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       Testing of the OPTIONS command failed. For more information, see Additional Details.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
An HTTP 401 Unauthorized response was received from the server. This may be the result of invalid credentials or a configuration problem on the Exchange Server.
HTTP Response Headers:
MicrosoftOfficeWebServer: 5.0_Pub
Content-Length: 83
Content-Type: text/html
Date: Fri, 12 Sep 2014 13:33:13 GMT
Server: Microsoft-IIS/6.0
WWW-Authenticate: Basic realm="academygropupuk.com"
X-Powered-By: ASP.NET
Elapsed Time: 316 ms
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 40319276
From my article:

HTTP 401 Error:
If you are getting an HTTP 401 error when testing on https://testexchangeconnectivity.com then you are probably entering an incorrect username or password, or you may have IP Address restrictions setup on your virtual directories (see IIS Settings above under prerequisites).
0
 

Author Closing Comment

by:censura
ID: 40419175
great
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question