Priviledge prompt on UNIX AIX 4.3

Good morning-

I am logging in under root for a UNIX AIX 4.3 server and everytime I login I have the graphical user interface of the Application software running on the server. All I am trying to do is get to a # prompt so that I can modify the /etc/hosts file for a printer ip address modification. Is there a way around the GUI once I login with root credentials that will leave me at the # prompt?
rbondsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Which way do you log in to the AIX machine? Can't you use the system console?

If access is via ssh you can try

ssh -tt hostname "ksh -p"

This will bypass the execution of ~/.profile

By the way, root should never get bothered with application stuff, that's bad practice.
0
rbondsAuthor Commented:
SSH is not recognized on the system. I know it's bad practice to have root affiliated with application stuff but I never set it up and at the moment just managing the system and making minor modifications. I am trying to use telnet any other ideas? I have users logged into the system and don't want to disrupt them.

Thanks for the feedback.

RB
0
woolmilkporcCommented:
If it's indeed a ~/.profile thing you can try to use FTP (if it's enabled on AIX) to temporarily rename this file so the shell won't find it any more.

After FTP'ing to your host just issue

rename .profile .profile.original

Log out with "bye" and retry accessing the box via telnet.

If it's not .profile try to find out which initialization file could be responsible (/etc/profile ?). and rename this one (might inhibit application login for other users temporarily!).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rbondsAuthor Commented:
Perfect. Renamed and was able to get to /etc/hosts under root credentials. Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.