SBS 2003 OWA Page not found error

I have a SBS 2003 running exchange.  I am able to log into the first page of the Remote Web Workplace internally, but when I click on the exchange link to log in and then enter my username/pw it gives me the HTTP 404 File or directory not found error.
I can also get to the RWW from the outside, but get the above error as soon as I click on the exchange link. I don't even get the login prompt.
Also in testing, when I go to http://localhost it returns Server Application unavailable in big bold red letters.  Any help would be greatly appreciated.
Thanks
invisimaxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kash2nd Line EngineerCommented:
check that the default website is up and running on the server in IIS and that it is the right port you are trying to access it on.
0
invisimaxAuthor Commented:
When I open IIS and navigate to the default website and right click on it and select browse I get the welcome screen that shows: My Company's Internal Website, Network Config WIzard, Remote Web Workplace, and Info and Answers.  When I click the RWW it goes to the: Server Application Unavailable in bold red letters.  I have attached a screen shot of the error I am getting in the event viewer that the page refers to.

Thanks
Capture.JPG
0
Alan HardistyCo-OwnerCommented:
Please just run the Connect To The Internet Wizard - change nothing in the options and let the Wizard Complete.  If it fails to complete, try running it a 2nd time and if that fails, then please advise where it fails.

The Wizard should resolve any issues (with any luck).

Alan
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

invisimaxAuthor Commented:
( I assume this is the CEICW wizard?) I had ran this previously and it was successful. I just reran it and it was all successful again.  But I still get the same Server Application unavailable error.
I did some more googling and it my results seem to point to the asp .net version and having 2 versions. but am am unsuccessful in narrowing this down any.
Any other help is greatly appreciated!
Thanks
0
Kash2nd Line EngineerCommented:
so if you type https://localhost/owa what do you get
0
invisimaxAuthor Commented:
The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

    Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
    If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
    Click the Back button to try another link.

HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

Technical Information (for support personnel)

    Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
    Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.
0
invisimaxAuthor Commented:
My page I use is localhost/remote. I am now able to get into the remote web work place but when I click on the Use outlook Web Access link on the right side it goes to The Page cannot be found. Http Error 404
So there has to be something in ISS somewhere, just not sure what to change.
Thanks
0
Alan HardistyCo-OwnerCommented:
If you follow Method 2 of KB883380, that will reset your Exchange Virtual Directories and then you can re-run the CEICW wizard and that should reset the permissions as per SBS defaults and then fingers crossed you will be running again.

If not, then my article about Activesync should help you check the default settings on the IIS directories:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Alan
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
invisimaxAuthor Commented:
Alan, I am going to try the steps in that KB article. Will this break anything as far as their mailboxes go? it mentioned at one point that the users would lose connectivity to their exchange mailboxes. Does that mean they just need to close outlook and reopen it once I am done with the steps?
Thanks
0
Alan HardistyCo-OwnerCommented:
Won't break the mailboxes, but OWA will be offline for a short while.

Nothing major - unless your users need 24x7x365 access!

Not aware that it will affect outlook as it's only IIS we are messing with here and Outlook uses MAPI to connect.
0
invisimaxAuthor Commented:
Alan,
I have gone through both of your articles and am still unable to get any further on this issue. For now we are going to close out the issue. Thank you very much for your persistent help on this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.