Centos 7/Windows 7 Dual Boot Problem

I have installed Centos 7 as a dual boot on my Windows 7 laptop.  Centos 7 installed successfully; however, when i reboot, I do not have an option to boot to my Windows 7 partition.  I instead get a list of various Centos systems to boot.  When i first installed Centos, the boot showed 3 flavors of Centos I could boot.  After I ran software update, the boot showed 4 options, with the main option have "(core) listed - but still no Windows 7.  The interface looks more like MBR vice grub
LVL 1
DCCoolBreezeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
You need to tweak grub2 configuration to detect other OS partitions.
0
David Johnson, CD, MVPOwnerCommented:
did you select grub on the installation .. what steps did you use?
0
DCCoolBreezeAuthor Commented:
Thanks for commenting... the installation never asked about grub.  i now know that grub2 is the boot loader.  I still have not figured out how to get the windows option loaded in grub2.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

DCCoolBreezeAuthor Commented:
I was able to solve the problem.  Centos loaded grub2 as the boot loader.  My windows 7 partition was intact, but not seen by grub2.  So I had to manually add windows 7.  To do this i did the following:

su -

#gedit /etc/grub.d/06_custom

#! /bin/sh -e
echo "Adding custom boot entry(s)" >&2
 cat << EOF
menuentry "Chainload Windows 7" {
    set root=(hd0,msdos1)
    chainloader +1  
}
EOF

#chmod 755 /etc/grub.d/06_custom

#grub2-mkconfig -o /boot/grub2/grub.cfg

i found this information on http://members.iinet.net/~herman546/p20/GRUB2%20Configuration%20File%20Commands.html

I just changed the last line to reflect grub2 (#grub2-mkconfig -o /boot/grub2/grub.cfg)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
You need to add something to /etc/sysconfig/grub, but i dont know what...
0
DCCoolBreezeAuthor Commented:
it worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.