Exchange 2013 correct internal & external url using wild card SSL and correct auto discovery to correctly populate mobile devices

Hello, I'm trying to get a step by step instruction to modify my Exchange 2013 server to correct invalid internal url's to eliminate the .local so outlook will not report an error on the certificate name and also adjust autodiscovery to correctly automatically populate ios and android mobile device once email and password is entered.  I have added a wild card SSL *.filotec.com.

Server Name:        filo-exch00
Internal FQDN:     https://filo-exch00.filo-tec.local
External FQDN     https://exchange.filotec.com
SSL Certificate      *.filotec.com
Server Type:         Windows Server 2012 Std & Exchange 2013 Std CU6

Right now after I removed my old certificate and installed the new certificate, outlook gives me the red X when connecting (The name on the security certificate is invalid or does not match the name on the site).  would like to know what command lines to type in the EMC to correct this issue and eliminate the .local.
Edgardo VazquezIT TechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
I have the URLs required here: http://semb.ee/hostnames2013

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Edgardo VazquezIT TechAuthor Commented:
Brilliant and easy, thank you for the link!  The only thing I would add is since it is a wild card SSL it was recommended to add the following.

Update your EXPR setting
Set-OutlookProvider EXPR -CertPrincipalName msstd:*.filotec.com

Update your EXCH setting
Set-OutlookProvider EXCH -CertPrincipalName msstd:*.filotec.com

Now for the very last part.  Is there a way to get IOS and Android mobile devices to self populate during AutoDiscovery?  Or must we always have it fail and enter server name, domain name manually?
0
Simon Butler (Sembee)ConsultantCommented:
Autodiscover is down the device, and that is very hit and miss.
I tell clients that they should presume Autodiscover for mobile devices will fail and have manual instructions ready.

I don't use wildcard certificates in any deployments I do, hence the lack of instructions for them. They are also not recommended with Exchange as you can get some odd results with some mobile devices.

Simon.
0
Edgardo VazquezIT TechAuthor Commented:
Thanks for your help..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.