WSUS 3.2 Worstations checked in but aren't reporting status.

I recently reconfigured our WSUS server because the last one crashed.  I gave it the same name and IP as the last WSUS server, synchronized all the updates and the computers are checking in but they are not reporting their status. I looked in the event log and it says that WSUS is working properly.
Josef Al-ChacarSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
how long has it been?
what is the frequency check configured for?
if you go to one client, open elevated command prompt and do wuauclt /detectnow and give it a half hour or so, do you see that machine status updated?
DonNetwork AdministratorCommented:
The easiest way would be to reset their WSUS client ID's

net stop wuauserv
reg Delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f
reg Delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f
reg Delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f  
reg Delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f
net start wuauserv
wuauclt.exe /resetauthorization /detectnow
Josef Al-ChacarSystems AdministratorAuthor Commented:
I set up the server last Thursday. They are configured to check for updates every three hours.

I have also tried both of these commands and they are still not reporting. I can see them but they are showing no yet reported and the Installed/ Not Applicable are showing 0%.

When i go to the clients i am getting the attached error.

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Seth SimmonsSr. Systems AdministratorCommented:
there is nothing attached
Josef Al-ChacarSystems AdministratorAuthor Commented:
Oh sorry about that lol

Here it is. I forgot to click upload
Seth SimmonsSr. Systems AdministratorCommented:
have you installed any post-SP2 updates for WSUS?

An update for Windows Server Update Services 3.0 Service Pack 2 is available
Josef Al-ChacarSystems AdministratorAuthor Commented:
Okay i fugured it out. I am slow lol. I had the wrong certificates loaded in IIS. That'll do it

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonNetwork AdministratorCommented:
Just an FYI, KB2720211 is old is the latest and includes KB2720211
Josef Al-ChacarSystems AdministratorAuthor Commented:
This is the solution. Make sure that WSUS has the right certificates.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.