orphan processes in Terminal Server 2008

I have a problem with a new Terminal Server 2008 I installed.  I have a domain running on a 2003 machine which hosts a TS and a TS License server.  For this Terminal Server 2003, I was able to specify on the domain user's profile a setting that would tell the Terminal server to kill its child processes if the session got disconnected.  This mechanism prevented me from having orphan sessions, as my users like to click on the X of the remote desktop window, rather than close their programs and log out.

Now, this new Terminal Server 2008 (and license server) are installed in a server which is not part of the domain.  Therefore, the user ids used to log into this TS are local to the machine.  As such, I don't have a way to tell the Terminal Server to kill its children when my users disconnect (instead of logging out) so I end up with lots of orphan sessions.  On top of all, they use the host to run software that uses floating licenses per user, so all those licenses remain in use while the orphan child of the TS is still alive, and I end up running out of licenses pretty quickly.

How can I configure the Terminal Server 2008 to kill all its children processes when the user disconnects?  I haven't found how to do this and I'm losing my brain!  Please, someone guide me on this one.
LVL 1
samjomooreAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Konstantinos TampourakisSystems AnalystCommented:
Try this,
go to Start->Administrative Tools->Terminal Services(Folder)->Terminal Services Configuration

Under "Connections" you'll find RDP-Tcp (Microsoft RDP 6.1), right click on it and select Properties, go to tab Sessions and check the box "Override user settings"->End a disconnected session and choose an appropiate time for Terminal server to end the sessions.

Regards,
Konstantinos
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.