Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Help to move HP config to CISCO

Posted on 2014-09-16
15
Medium Priority
?
222 Views
Last Modified: 2014-10-16
Hi Experts,

now I have a HP switch running -> ProCurve Switch 2510G-48 -> J9280A
We have bought a new switch from CISCO and I have to move the config or create a new config.
The new Switch is -> CISCO 2960-S-48

The basic setup is done and now I need some help with the rest of commands.
Can you assist me here ?
0
Comment
Question by:Eprs_Admin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 3
  • 2
15 Comments
 
LVL 17

Expert Comment

by:James H
ID: 40325196
Is the HP just a flat switch or does it have VLAN tagging on it?
Can you post the config to see what needs to be setup on the 2960?
0
 

Author Comment

by:Eprs_Admin
ID: 40325510
Yes the HP switch has vlan tagging.

Some ports are tagged -> is this in cisco a trunk port ?
0
 

Author Comment

by:Eprs_Admin
ID: 40325525
HP Config

vlan 1
   name "DEFAULT_VLAN"
   untagged 1-37,43-44,46-47
   ip address 10.1.2.201 255.255.255.0
   tagged 45
   no untagged 38-42,48
   ip igmp
   exit
vlan 10
   name "SAP"
   untagged 39-42
   no ip address
   ip igmp
   exit
vlan 20
   name "voip"
   untagged 38
   tagged 45
   exit
vlan 953
   name "LWL-WAN"
   untagged 48
   tagged 45
   exit

Open in new window

0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 
LVL 57

Expert Comment

by:Pete Long
ID: 40326098
Is port 45 an uplink to another Switch?
0
 
LVL 17

Expert Comment

by:James H
ID: 40326201
I would avoid using VLAN 1, just not recommended.
Creating the other VLAN's are simple enough:

switch# conf t
switch(config)# int vlan (number) <-- no parenthesis. ex. int vlan 953
desc LWL-LAN

This will create the VLAN's in the switch database. Repeat for each VLAN.

Now, it does look like port 45 in an uplink, where does that go?

For each port, from the config prompt:

interface gi1/0/38 (example)
switchport mode access
switchport access vlan 20 (as per your HP switch, port 20 seems to be a VOIP port).
spanning-tree portfast  **Optional but I would add it for safety

to save, either type exit or hit ctrl + z and then type wr mem
0
 

Author Comment

by:Eprs_Admin
ID: 40326251
yes this port 45 is a link with a fibre cable to another smaller switch.
0
 

Author Comment

by:Eprs_Admin
ID: 40326257
this port 45 is it a trunk port in cisco,
You see in HP it is a tagged port but not for each vlan.
0
 

Author Comment

by:Eprs_Admin
ID: 40329829
When I have 4 vlans and a tagged port over 3 vlans, is is a trunk in cisco ?
0
 

Author Comment

by:Eprs_Admin
ID: 40329867
I used this command in cisco to allow just 3 vlans over the trunk

switchport trunk allow vlan 1,20,953

Right ?
0
 
LVL 17

Expert Comment

by:James H
ID: 40330076
commands:

switchport mode trunk
switchport trunk encap dot1q
switchport trunk allow vlan 1,20,953
0
 

Author Comment

by:Eprs_Admin
ID: 40330303
ok I will try this. thanks.
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 2000 total points
ID: 40331215
>>When I have 4 vlans and a tagged port over 3 vlans, is is a trunk in cisco ?

Yes :) See...

HP and Cisco - VLANs and Trunks Confusion!


PL
0
 

Author Comment

by:Eprs_Admin
ID: 40340975
Hi,

this command is not working on my Cisco switch :

switchport trunk encap dot1q

Do you know why ?
0
 

Author Comment

by:Eprs_Admin
ID: 40340989
on my cisco I have set

line vty 0 4

But the password is written in plain text in the config. How do I change it ?
0
 

Author Comment

by:Eprs_Admin
ID: 40341002
I have one HP command : ip igmp

for what is it and do I have to put it on my cisco device ?
0

Featured Post

Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question