Solved

Exchange 2010/Outlook 2007 certificate error mismatch

Posted on 2014-09-16
9
938 Views
Last Modified: 2014-09-17
I have just converted from Exchange 2003 to Exchange 2010. I installed a UCC SSL certificate from go daddy on my exchange 2010 server. The Outlook 2007 clients started getting a certificate mismatch warning because the built in certificate that the Outlook clients were pointing to was the internal name of the server (blgexchserv1.blg.local).
I did some research and came accross this post:
http://exchangeserverpro.com/outlook-2007-clients-display-certificate-mismatch-error-after-mailbox-migration/
I attempted to  change the URL of the Autodiscover services within Exchange 2010. I completed the first entry, but the outlook clients are still getting the certificate error. I did not think I needed to modify the web services url at all. I tested OWA internally and it is resolving fine. What am i doing wrong? what else do I need to do to get rid of the error.
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 25

Accepted Solution

by:
-MAS earned 350 total points
ID: 40327314
0
 

Author Comment

by:williamstechnologygroup
ID: 40327332
the auto discover internal is set correctly.... I know that IIS is using the Godaddy cert because active sync and OWA are both working correctly with no certificate errors. I am not sure why the clients are persisting in looking for the internal cert with the .local name....
0
 

Author Comment

by:williamstechnologygroup
ID: 40327352
the OAB default website for internal is pointing to the .local name of the server, but would that generate the certificate error in outlook?
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 9

Expert Comment

by:Zacharia Kurian
ID: 40327362
The certificate mismatch occurs because the Autodiscover Service and/or Availability Service use the FQDN of the Exchange 2010 host in their URL (eg https://your server.domain.local/AutoDiscover/AutoDiscover.xml) but the IIS instance has an SSL certificate that does not match that name.

So just follow the links Posted by the expert MAS.
0
 
LVL 12

Assisted Solution

by:SreRaj
SreRaj earned 100 total points
ID: 40327381
Hi,

You could add internal FQDN name of the CAS server as a Subject Alternate Name in UCC. This helps to get rid of certificate warnings internally.

https://www.digicert.com/ssl-support/exchange-2010-san-names.htm

Also, it is good to add EWS URL, because of OOF uses web services. You could run 'Test E-mail Configuration' from a connected machine. This will list all the URLs used by Outlook both thru RPC and using HTTP. You could verify that all these URL names are added as SANs in the UCC.

http://premnair.wordpress.com/2010/07/03/configure-ews-autodiscover-owa-oab-ecp-on-exchange-server-2010/
0
 
LVL 25

Expert Comment

by:-MAS
ID: 40327387
@SreRaj
You wont be able to add internal FQDN in your certificate in the near future.
Almost all CAs stopped adding internal FQDN to the certificate.

And it is not a good practice to add internal FQDN in your exchange certificate.
0
 
LVL 9

Assisted Solution

by:Zacharia Kurian
Zacharia Kurian earned 50 total points
ID: 40327415
You wont be able to add internal FQDN in your certificate in the near future.
Almost all CAs stopped adding internal FQDN to the certificate.

And it is not a good practice to add internal FQDN in your exchange certificate.

very true MAS. Adding the internal name to SSL was just tweak but then all started to realize the security issues related to it and I think many SSL providers do not do so now, rather they do issue wild card SSL.
0
 

Author Comment

by:williamstechnologygroup
ID: 40329084
Yes, the internal names on a san cert are going away. Godaddy made that clear. I ended up calling Microsoft after I had exhausted all other possibilities. I had performed the correct scripts, but the outlook clients were not responding. THanks to MAS for the tip on the Outlook Test email auto configuration. will reward points based on relativity.... thanks...
0
 

Author Closing Comment

by:williamstechnologygroup
ID: 40329087
Contact Microsoft for final resolution
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question