Server 2012 RemoteApp programs not working outside network.

I have a single server running Windows 2012 R2 with RD services installed. I have a public dns assigned and a UCC SSL certificate installed. I can access RDP inside and outside the network using the public dns name with full RDP desktop. However my server name is 'servername.mydomain.local' and when i create a webapp the local server name is attached to the rdp quick link so users cannot access this outside.

On server 2008 I am able to change this address when building the remoteApp. I cannot seem to do that on 2012.

I found this post that is related to my issue and followed the instructions but it did not change the computer name that the remoteApp is deploying.
Dennis JansonIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
RDS in 2012 really needs the broker service to be effective, and for outside access, you pretty much need to use the gateway service. While you can strong-arm RDP without it by disabling NLA and such, you can't really with remoteapp.
0
Dennis JansonIT ManagerAuthor Commented:
I found a solution on a blog that help me get the outside access using remoteApps to work. It had to do with the redirect behavior within IIS.


http://blogs.msdn.com/b/rds/archive/2011/09/07/how-to-troubleshoot-logon-attempt-failed-messages-when-connecting-through-rd-gateway.aspx
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
In IIS: IIS Sites --> Default --> RDWeb --> Pages --> Application Settings --> DefaultTSGateway:

Set that to your RD Gateway access URL.

Then restart IIS.

Your RemoteApps will then be able to find the proper gateway inbound.

When you created your collection bring up its properties and make sure the URL is specified in RD Gateway settings too. This generates the correct settings in the RDP files,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dennis JansonIT ManagerAuthor Commented:
All of the steps mentioned in each post are necessary to have RemoteAPP work publicly If you have you single RDP server setup as a *.local computer name.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.