Solved

Word 2010 and Outlook 2010 (Windows 7) - Error Message : "Word couldn't send mail because of MAPI failure unspecified error"

Posted on 2014-09-17
9
283 Views
Last Modified: 2015-05-05
In my environment we have Office 2010 on Windows 7.  Since moving to Office 2010 (we did fresh OS installs when we upgraded) I'm seeing the following error on a lot of my user's systems when they try to use the "Send As Attachment" QAT button from within Word 2010.

"Word couldn't send mail because of MAPI failure unspecified error"

Here is the strange part.  The FIRST time you use the "Send As Attachment" button, it works flawlessly, creating a new email in Outlook 2010 and putting your Word document in as an attachment.  You can send the mail off and not think about it again.  However, if you attempt to use the "send as attachment" button a second time, either for the same document OR a different document, that is when Word kicks out the MAPI failure error listed above.  This happens each and every time from within Word that a user tries to send a document as an attachment a SECOND time in the same session.  If you close Word and Outlook, and reopen both, the session resets and you can send ONE attachment again.

This is killing productivity.  I have been all over the web and seen everything tried to fix this, and came up short.  Most people seem to have the problem right away and all the time, unlike my people who can get one email off before the problem forces them to close down.  I've tried updating Office, I've tried completely uninstalling Office and reinstalling, I've tried removing my third-party add-ins (we have a metadata scrubber in Outlook), nothing works.  What could be causing Word and Outlook to lose their MAPI connection to one another just by creating/sending an email?  

Any advice would be appreciated.  I've pretty much exhausted all my ideas thus far.
0
Comment
Question by:Remy001
  • 5
  • 3
9 Comments
 
LVL 43

Accepted Solution

by:
Davis McCarn earned 500 total points
ID: 40330074
Run fixmapi which ought to be in Windows\System32.
0
 

Author Comment

by:Remy001
ID: 40331510
Sorry, should have mentioned that fixmapi.exe was one of the first things I tried.  No effect on the issue at all.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 40331776
And you also tried repairing Office in Programs and Features?
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:Remy001
ID: 40332458
Yes, here is the list of things I have tried thus far:

-fixmapi.exe
-Repair Install of Office 2010 from Programs and Features
-Uninstall of Office 2010 from Programs and Features, reboot, reinstall Office 2010
-Uninstall/Reinstall of 3rd party Add-Ins that modify both Word and Office
-As of yesterday, I also did a complete rebuild on one of the affected machines (to resolve an unrelated issue on the machine it made more sense to simply re-image it and reinstall the custom software after re-imaging).  Even that did not resolve the problem with MAPI errors.  

At this point I am down to a couple of things I still want to try.  I want to blow away a user's profile and totally rebuild from scratch to see if it's something in the user profile versus the actual image/software installation.  I also want to test dumping an image to a machine, then testing each step of the way as we install all of the third-party and other custom software that gets added post-image to see if I can narrow down what might be causing the issue.  Any other suggestions would be most welcome.  

Thanks for your time thus far!
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 40332498
Is there any chance the files are larger than 20MB?
http://www.slipstick.com/outlook/email/outlook-2010s-default-attachment-size/

And/or, I did find this:

"Actually I got this one solved and posted about it, but the post seems to
 have disappeared - the answer was to start the client application (in my
 case Word 2007) in administrator mode. This isn't the easiest of things to
 do - for others' interest, you'll have to find the actual .exe file (in my
 case Winword.exe in Office12 directory), create a shortcut from it to the
 desktop and then right click on the shortcut, choosing the compatibility tab
 and checking the 'run as administrator' box."
http://www.outlookforums.com/threads/14219-word-couldnt-send-mail-because-of-mapi-failure/
0
 

Author Comment

by:Remy001
ID: 40332685
Files are small, often less than 1MB even, certainly less than 20.

I have WINWORD.EXE set with the checkbox to Run As Administrator, still no joy.  

I'm going to try removing any and all non-Microsoft add-ins from both Outlook and Word to see if the issue still happens with a "vanilla" setup.
0
 

Author Comment

by:Remy001
ID: 40333093
BREAKTHROUGH!

I went back into Outlook 2010 and under Options, then Add-Ins, then Work With COM Add-Ins I unchecked every add-in that I knew was not a Microsoft Office add-in.  Restarted the machine, opened Outlook 2010 and Word 2010, and I can now attach documents multiple times without seeing the MAPI error.  Tested this twice just to make sure I wasn't hallucinating.  ;-)

So now I need to turn each add-in back on one at a time and test after each activation to discover which third-party add-in is responsible for the MAPI error.  

I will update when I reach a conclusion.
0
 

Expert Comment

by:matedwards
ID: 40760074
just a quick note.. it happened to a user here who saved the document in Rich Text Format. As soon as it was saved back as Word it all worked normally.
0
 

Author Comment

by:Remy001
ID: 40760165
Forgot to revisit this issue after successfully resolving it.  

As I mentioned above, disabling all COM add-ins in Outlook resolved the issue, but we can't exactly work the way we're used to without the additional apps we use with Outlook, so I went through and tested them one by one.  Turns out there was a problem with a third party add-in from NetDocuments, our cloud-based document management system.  I forwarded all my research over to NetDocuments, and they were able to rewrite the add-in to resolve the MAPI errors.  Once I rolled out the new add-in to all my systems, the problem was resolved.

Very belated points to DavisMcCarn for several valid and thoughtful suggestions.  Your assistance was much appreciated.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
Learn how to create and modify your own paragraph styles in Microsoft Word. This can be helpful when wanting to make consistently referenced styles throughout a document or template.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question