Is there a way to turn off the weird shift / ctrl "lock" behaviour in Windows 8.1 (if you hit the shift or ctrl key by mistake)

I'm not sure if this is a WIn 8 accessibility issue (being able to enter control and shift key combinations one key at a time) or something to do with my MS Sculpt Comfort Keyboard but often, I find that after I've hit the control or shift key by mistake, the keyboard seems to lock in the state of the control or shift key so everything I type afterwards is as if I was holding down the control / shift key until I tap the control or shift key again.

I'm never sure which key it was that I accidently pressed and I find this to be really annoying.

Is there any way to turn this off?

Is this something that was introduced with Windows 8? I don't recall it happening with Win 7.

Or could this be something to do with my MS Sculpt Comfort Keyboard? I'm in Canada where we have a lot of (annoying) bilingual keyboards.

Thanks
ou81aswellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul MacDonaldDirector, Information SystemsCommented:
It sounds as if you've turned on Sticky Keys by mistake.  Here's how to turn it off.
0
ou81aswellAuthor Commented:
Thanks, but it's not on.

Turn on Sticky Keys is not checked in Control Panel -> Ease of Access Center -> Make the keyboard easier to use.

.
0
Paul MacDonaldDirector, Information SystemsCommented:
This person had a similar issue that turned out to be related to power management.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

ou81aswellAuthor Commented:
Thanks. I've attempted the solution of turning off power management to the keyboard. I'll wait to see what happens.
0
ou81aswellAuthor Commented:
I forgot about this question. It's been 18 months and the problem seems to have gone away so the power management tip seemed to be the solution.
0
ou81aswellAuthor Commented:
Thanks paulmacd!
0
Paul MacDonaldDirector, Information SystemsCommented:
Very happy to have helped.  Thanks for the points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.