Solved

IIS8.5 Win2012 R2 - not loading any websites

Posted on 2014-09-17
2
386 Views
Last Modified: 2014-11-25
Been using 2003 IIS6.0 for years...
So I am more than perplexed...
none of our test sites will load on this new server...
IIS 8.5  - Win2012 R2 - joined to a domain.

I have:
a.) verified that yes, services are running.
b.) Set a one page website..  made it use a default I/P address..
    I get document not found  (even though index.htm - exists, and is
    part of the default doc listing)
   HTTP Error 404.0 - Not Found
c.) Did test validation of authentication.   Told me I needed to make sure that
     NetWorkServices could read that directory.  Did that.
d.) simply type in  localhost ... get same error message

Would think it would be something of a "duh" moment when I figure it out.. but I am stumped.  Any ideas or good jokes would be welcomed at this point in time
0
Comment
Question by:datafarmer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 28

Accepted Solution

by:
Dan McFadden earned 500 total points
ID: 40329825
Let's get the first silly question out of the way:  Stop all websites you created. Stop any AppPools that you created.  Make sure the Default App Pool and the Default website is running.  When you hit the server with a browser, do you get the IIS welcome (default) page?

If not, there is an issue with the IIS installation.  If you do get the default site, all good, then we can move on...

Reference:  http://www.iis.net/learn/install/installing-iis-85/installing-iis-85-on-windows-server-2012-r2

Dan
0
 

Author Comment

by:datafarmer
ID: 40465783
Apologize.. have been out on leave.
What we found out was, yes we could do the above....
But that was about it.
~~~
Apparently in Win2012, installs... installing framework 3.5 and installing IIS    DOES NOT mean that sites running 3.5  will actually run.  There is additional installs, after the IIS install ( think options 3 of 5) .. where it simply says "ASP" as part of the install... AND that runs 3.5.  

Accepted the above solution.. because we had to go clear back to the basic install, and go forward.
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
The reason that corporations and businesses use Windows servers is because it supports custom modifications to adapt to the business and what it needs. Most individual users won’t need such powerful options. Here I’ll explain how you can enable Wind…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question