2008 R2 Hyper-V VM hangs after logging in

Microsoft's great Hyper-V has completely screwed me again.  I have a 2008 R2 virtual machine and I was running 4 VM's.  I just got a new server and installed 2012 R2 and moved all the VM's over.  This one VM in particular (which is running 2008 R2 and Exchange 2013 Standard) would not start the Exchange Transport service on the new server.  So I tried deleting the NIC from the VM when it was on the original server and shutting it down and THEN moving it to the new server (export feature apparently doesn't work going from 2008 to 2012...thanks MS for letting us all know that BEFORE we purchase your over priced software).  And now either the new server or old I am completely screwed, I can log into the VM but pretty much after that it's a horrible SLOW performance.  So slow that when I immediately try to right click on Network and go to Properties it just hangs.  I've tried adding a new NIC to the VM, I've tried deleting the NIC from the VM and starting up with no NIC.  The problem may be Exchange, but how do I fix it?  I can't believe Hyper-V is THIS friggin unstable!!!!
tphelps19IT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tphelps19IT ManagerAuthor Commented:
So if I restart in safe mode with networking then Windows installs the NIC ok and I can even get a ping to respond from the outside.  Problem is as soon as I restart in regular Windows it freezes again as soon as I try to go to into Network Properties.  Also if I do an ipconfig it shows a regular windows IP.
Dash AmrSenior Specialist(PM)Commented:
lets get to this Step by Step but before PS: honestly you shouldn't modify the actually working VM by removing the NIC at least you had exchange working - and You can't blame MS for that :) anyway,

ON the Old Server log into your Host if you can and add the NIC back to the VM from the Hyper V management console

That should at least get your Exchange back up and running - try this or maybe let us know more about the situation to get a clear picture.
Dash AmrSenior Specialist(PM)Commented:
I assume its Exchange 2010 or above so  let me know how did Exchange Transport service stopped

After and update ?
before an update ?
have you installed or uninstalled a specific software ?
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

tphelps19IT ManagerAuthor Commented:
I think I got it working!!  Get this....  I tried everything and the network properties window kept freezing so finally just said screw it and went and got something to eat and when I came back (like 45 min later) it finally had unfroze and there was a balloon window in the bottom right saying windows had installed a new virtual adapter NIC and then I just gave it an IP and restarted, and viola!

However I did do ONE thing that may have contributed to fixing it.  I disabled every Exchange service and then restarted so they were all disabled upon restart.  I was convinced that's what was causing the hanging but when it didn't that is when I Just left and went to eat.  Weird...weird...weird.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dash AmrSenior Specialist(PM)Commented:
Must have been a delicious meal !!!   all good glad you got it working :)

tphelps19IT ManagerAuthor Commented:
One note though in case anybody follows this thread, the ORIGINAL problem was still there which was the Exchange Transport service was not starting.  Quick note about Exchange 2013:  if you move it to another server via VM, you HAVE to manually re-add the bindings for DNS lookups.  I know it's so stupid and I remember dealing about this with MS back when I first got Exchange 2013.  It's under the Admin Center > Servers > DNS Lookups.  By default it's set to "All available IP v4 Addresses" but apparently that's another gotcha from MS because that excludes VM's.  For VM's you have to specifically specify the Microsoft Virtual Host Adapter on both internal DNS lookups and external DNS lookups.
tphelps19IT ManagerAuthor Commented:
Because I figured out the solution myself before anybody else did.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.