Solved

Remote Desktop Connection Disallows Credential Saving

Posted on 2014-09-18
6
254 Views
Last Modified: 2014-09-19
I'm using a Windows 7 PC to connect to a Windows Server 2008 R2 via Remote Desktop Connection. I'm not being allowed to save credentials.  I get the following message:
“Your system administrator does not allow the use of saved credentials to log on to the remote computer (IP Address or host name) because its identity is not fully verified.  Please enter new credentials.”

I've already tried without success the typical Google solution, to use gpedit.msc to Enable the four "Allow Delegating..." policies with the TERMSRV/* setting and then using gpupdate /force to apply the new policy.

Looking forward to typing my password less often in the near future. :)
0
Comment
Question by:slamond
6 Comments
 
LVL 38

Expert Comment

by:Jim P.
ID: 40331937
Have you looked at RD Tabs  from  Avian Waves. Free app that runs over the remote desktop. That may be your answer.
0
 
LVL 30

Expert Comment

by:mtz1of4
ID: 40332262
Are you the administrator on the server? If not, have you asked the admin to allow saving credentials?
0
 
LVL 38

Accepted Solution

by:
Aaron Tomosky earned 500 total points
ID: 40332758
I use Remote Desktop connection manager, free from Microsoft. It bypasses the whole save my passwords In the registry part of mstsc.
0
Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

 

Author Comment

by:slamond
ID: 40333102
Yes, I am the Admin but wasn't thinking in terms of the server policy. I will checkout Remote Desktop Connection Manager. But I'm also curious if another option might be to Enable Credentials Saving, but is it possible to define it for me, and possibly a few others, individually? I use a PC, but most of our users connect with thin-clients that are not password protected, hence my having the system policy disallowing Credential Saving.
0
 

Author Comment

by:slamond
ID: 40333371
I have installed Remote Desktop Connection Manager and I expect that will work for me.
0
 

Author Closing Comment

by:slamond
ID: 40333374
I have installed Remote Desktop Connection Manager and I expect that will work for me.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now