Solved

Outlook 2007 on RDS frequently loses connection to Exchange 2013

Posted on 2014-09-18
6
1,070 Views
Last Modified: 2014-09-23
Hi there,

we have a bit of a situation at one of our clients.
Case is as follows:

Exchange 2013 server on windows 2012 R2, RDS on an other Windows 2012 R2 with outlook 2007 (client couldn't afford to replace Office as well at this time).

Exchange is migrated from exchange 2007 on a Windows 2003 server.

All mailbox have been migrated and after a few weeks we removed the exchange 2007 from the coexistance.
And that's when the problems started.

No day later after we moved the Public folders to exchange 2013, recreated some connectors and de-install exchange 2007, we are getting calls from the users that that outlook is repeatedly telling that the connection to exchange was lost and and recreated. Ofcourse when they try to send an e-mail and the connection gets lost the mail gets stuck in the out-box untill outlook reconnects.

Accourding to the event logs on the remote desktop server, the connection losing and reconnecting occurse ever 2 or 3 minutes. And stops when most people go home at the end of the day. Ofcourse it starts in the morning again.

So. What we already know:

- Users are opening multiple mailboxes (their own + shared mailboxes)
- We can't turn on cache mode cause it's not supported on outlook 2007 in RDS. We tried a registry tweak to enable it anyway, but that didnt work
- We notice that one outlook session makes a lot of RPC over HTTP connections (6 for a single mailbox, 24 for someone using multiple mailboxes).

Strangest thing is. We didn't have the problem when the exchange 2007 server was still up but not in use. All outlook 2007 were already connecting through the http/rpc connection via the new exchange 2013/iis apppool.

So... what to do.

I know we can force the client to buy office 2013 for all users (VLK license) but since Outlook 2007, Exchange 2013 should work together, I am wondering if there is any limit we can tweak so there are less reconnections.

Hope someone can help.
0
Comment
Question by:Joost
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 34

Assisted Solution

by:it_saige
it_saige earned 500 total points
ID: 40331508
Open Exchange Powershell and check your outlook anwhere settings.

Get-OutlookAnywhere

I am willing to bet that you do not have Negotiate set in your IISAuthenticationMethods, ExternalClientAuthenticationMethod or InternalClientAuthenticationMethod settings.

Try setting this with:

Get-OutlookAnywhere –Server (hostname) | Set-OutlookAnywhere -InternalClientAuthenticationMethod Negotiate -InternalClientsRequireSsl $true -ExternalClientAuthenticationMethod Negotiate -ExternalClientsRequireSsl $true -IISAuthenticationMethods NTLM,Basic,Negotiate

Dont forget to run an iisreset when finished.

-saige-
0
 

Author Comment

by:Joost
ID: 40331759
IISAuthenticationMethods, ExternalClientAuthenticationMethod or InternalClientAuthenticationMethod settings, were set to "NTLM".

So you were right about it not having Negotiate.

I've changed the settings. So tomorrow morning I will hopefully see improvement.

I noticed that the RPC/HTTP settings in Outlook automatically were set to NTLM authentication. Should I also change them to Negotiate?
0
 
LVL 34

Expert Comment

by:it_saige
ID: 40331956
That was going to be my next question.  Yes, set them to negotiate as well.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Accepted Solution

by:
Joost earned 0 total points
ID: 40332150
Thanks for the tip. To bad. This morning after a few users had logged in on the Remote Desktop server the Application Event ID 26 were popping up again and users were getting the same connection messages from outlook.

On an other forum I was reading something about Outlook using public folders for "ready/busy" status and such. Not that it directy had anything to do with my problem I started a search on the new Exchange 2013 server and noticed that de "publicfolder mailbox" that was created during the migration from exchange 2007, still was in "HoldforMigration" status.

Since the company never used the PF, nobody noticed that the whole public folder wasn't accessible. One google search lead me to a tip to recreate the PF-mailbox.

Since it wasn't containing any information I removed it with the Exchange 2013 Admin Center. And created a new one.
At the exact moment the new PF was created and I could access it with outlook on the RDS. The event 26 stopped !!!

So, it turned out to be a public folder issue. Some how during the transition from the public folders in exchange 2007 to 2013 something went wrong.
0
 
LVL 34

Expert Comment

by:it_saige
ID: 40332446
Glad to hear that you got the issue resolved.
0
 

Author Closing Comment

by:Joost
ID: 40338640
Saige helped me a lot in directing me to the right path. Though it turned out to be an other problem that we stumbled upon while looking for settings that could help.
0

Featured Post

Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question