Should RDP Clients be pointed directly to the Windows 2012 R2 RDCB Connection Broker Server in RDS?

Hello,

We are attempting to configure a "simple" RDS 2012 R2 Farm.
One RDS Connection Broker non-HA, with license server (a Standalone Server), and 4 separate RDSH 2012 R2 Servers.  
We have configured the Connection Broker "Collection" with the 4 RDSH Servers and called RDSFarm.

We want the users to connect to the 4 RDSH Servers Remote Session Desktops via RDP 3389 (Users are using a Wyse T10D Terminal, but only using the RDSH Desktops not the ThinOS desktops of the Wyse Terminal).  
We do not have a RDS Gateway configured, as we do not anticipate the need for remote external connections.
Our DNS has configured the 4 RDSH servers as 192.168.0.101 - 104 and the RDCB as .110.
We have made a DNS RR of the 4 RDSH with the DNS name of RDSFarm.

Couple of questions/issues:
1) Should we be pointing the users directly to the RDCB server?
     And if so how do I set this up on the RDCB server?
     What I've done:  I've tested pointing users RDP sessions directly to the RDCB (.110) server, however they receive the error that the user does not have access, which makes sense in they don't have access to the RDCB server.  
Are we supposed to configure a RDGateway and it would seem to solve this issue, however is RDGateway a requirement for my setup or is it that I simply am missing something in the configuration of RDCB?

2) Currently when a user connects via RDP to the RDSFarm (DNS RR), they are requested to login their domain credentials twice.  
I'm assuming that this is because they are routed to one RDSH server first via DNS RR and then the RDCB server takes over and reroutes them to a a different RDSH server.  
Is there a way I can fix this so they only have to enter credentials once?

3) Does the RDP Client need any configuration in the "Gateway settings" section, perhaps entering in the RDCB server settings?

I hope this makes sense, it's been difficult to find instructions for simplistic configurations of RDS 2012 R2, I.E. setups without the need for HA, RDGateway, RDWeb, RDApps.  

Thanks for your help!
Anthony LarsonIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
are the users in the remote desktop users group?
0
Casey WeaverNetwork EngineerCommented:
Did you manage to get anywhere with this?
0
Anthony LarsonIT ManagerAuthor Commented:
Solutions:

1) Should we be pointing the users directly to the RDCB server?
Answer:  No point users to the DNS Aliases that points to all the MS RDCH (Host) servers.  The MS RDCB (Remote Desktop Connection Broker) Server will then assign the RDP user to a server.

2) Currently when a user connects via RDP to the RDSFarm (DNS RR), they are requested to login their domain credentials twice.  
I'm assuming that this is because they are routed to one RDSH server first via DNS RR and then the RDCB server takes over and reroutes them to a a different RDSH server.  
Is there a way I can fix this so they only have to enter credentials once?
Answer:  Enable Network Layer Authentication on the MS RDCB Server -> Server Manager, Remote Desktop Services, Collection

3) Does the RDP Client need any configuration in the "Gateway settings" section, perhaps entering in the RDCB server settings?  
Answer:  No
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anthony LarsonIT ManagerAuthor Commented:
I had to work extensively with Microsoft Support and Dell Support and making Microsoft Windows 2012 R2 Remote Desktop with Connection Broker to work correctly and with stability.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.