Adding outlook account onto PC

Hi All,

I have a customer who requires their exchange emails setting up onto their PC. The PC is not part of a network and is running XP Media center edition. The office version is 2007.

I try to add the account the normal way (by connecting using HTTP) and each time I go to "check name" and enter the password I am going into a loop even though I know the password is correct. After many attempts I am presented with the message "The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action"

I have tested this on my outlook (running outlook 2010 on a windows 8 PC) and it works perfectly fine.

Any help would be greatly appreciated!
Stuart SmithTechnical Director Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

it_saigeDeveloperCommented:
What is the exchange server version?

-saige-
0
Gabriel CliftonNet AdminCommented:
If the computer is not part of the domain and the Exchange server is, are you entering the credentials as Domain\UserName?
0
Joshua GrantomSenior Systems AdministratorCommented:
Gabriel is right,

you have to use DOMAIN\Username as the username and if the computer is on a different network than the exchange entirely, you must use the public IP address or A Record for the mail server (mail.mydomain.com)
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Stuart SmithTechnical Director Author Commented:
Yes that's correct i'm typing the domain\username and it's still not working for me. One thing I should of mentioned is that the email uses a POP3 connector however we just set the accounts up like exchange accounts and we never normally have any issues.

The exchange server version is Exchange 2010.
0
it_saigeDeveloperCommented:
What authentication methods do you have enabled for OutlookAnywhere?

Have you verified that your certificate Common Name matches the one specified by the msstd field found on the XP client?

-saige-
0
Stuart SmithTechnical Director Author Commented:
Basic authentication when configuring the HTTP setup. Yes the certificate name matches the msstd entry. Still stuck as to why it's not working.
0
it_saigeDeveloperCommented:
Does outlook /rpcdiag show that it is attempting to connect to the correct rpc server?

-saige-
0
Rob ArmstrongOwnerCommented:
Also check the IPv4 settings on the machine itself. Make sure that it's pointing to the correct DNS server IP if it's static. If it's not static, maybe make it static and point it correctly just to check?

Or, try pointing to another known good DNS server?
0
Stuart SmithTechnical Director Author Commented:
Hi Saige, I will test this now.

Rob- I will also have a look at the IPV4 settings on the PC and have a little play with the DNS
0
Stuart SmithTechnical Director Author Commented:
Saige- RPCdiag shows disconnected and won't accept the password when I type it in.

I have tried changing the DNS settings to the Google settings however it still won't accept it. Everytime I try to type in the password it goes into a loop and I know that for 100% it is the right password.
0
Rob ArmstrongOwnerCommented:
Apologies for not fully reading your question earlier. I was thinking it WAS joined to the domain, but you said in your OP it wasn't. Sorry.

So, next question: was that Windows 8/Outlook 2010 PC also not joined to the domain? If it was domain joined, maybe you have an issue w/ mail.domain.com autodiscover. If it wasn't domain joined and it still worked, I'm not sure...have there been any autodiscover changes or certificate expirations recently?

Also, is Outlook Anywhere enabled on your client access server within the Exchange Management Console/Shell?
0
Stuart SmithTechnical Director Author Commented:
Hi Rob, no worries!

Yes that PC was joined to the domain in fact it was my PC and worked perfectly. Outlook anywhere is enabled in the exchange management console on the server.

We seem to have all the correct settings in place I just don't know why it's not working.
0
it_saigeDeveloperCommented:
Please go to https://testconnectivity.microsoft.com/ and complete the Microsoft Office Outlook Connectivity Tests.

Please post the results of these tests (the HTML or XML results).

-saige-
0
Stuart SmithTechnical Director Author Commented:
Hi Saige,

Please see attached.
RCATestResult.xml
0
it_saigeDeveloperCommented:
The test indicates two problems.

First your certificate is registered to (uses a common name of) remote.bsplastics.co.uk but you are attempting to connect to bs-motors.co.uk.

Second, the cname for autodiscover is missing. (this however, is not entirely a bad thing as you can manually configure your settings).

What output do you get from the following cmdlets:

Get-OutlookAnywhere
Get-OutlookProvider
Get-ExchangeCertificate (you can remove the thumbprints)

-saige-
0
Stuart SmithTechnical Director Author Commented:
bs-motors.co.uk is an accepted domain with exchange management console?

Get-OutlookAnywhere:
RunspaceId                      : e0af6447-03ee-44b0-87c2-4de92e42341e
ServerName                      : BSP-SBS-01
SSLOffloading                   : False
ExternalHostname                : remote.bsplastics.co.uk
ClientAuthenticationMethod      : Basic
IISAuthenticationMethods        : {Basic, Ntlm}
XropUrl                         :
MetabasePath                    : IIS://BSP-SBS-01.bsp.local/W3SVC/1/ROOT/Rpc
Path                            : C:\Windows\System32\RpcProxy
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
Server                          : BSP-SBS-01
AdminDisplayName                :
ExchangeVersion                 : 0.10 (14.0.100.0)
Name                            : Rpc (Default Web Site)
DistinguishedName               : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=BSP-SBS-01,CN=Servers,CN=Exchange A
                                  dministrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,
                                  CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=bsp,DC=local
Identity                        : BSP-SBS-01\Rpc (Default Web Site)
Guid                            : b9985c99-5b87-4548-8a5d-11d7c61551d4
ObjectCategory                  : bsp.local/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
ObjectClass                     : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
WhenChanged                     : 18/06/2012 23:27:59
WhenCreated                     : 18/06/2012 23:27:59
WhenChangedUTC                  : 18/06/2012 22:27:59
WhenCreatedUTC                  : 18/06/2012 22:27:59
OrganizationId                  :
OriginatingServer               : BSP-SBS-01.bsp.local
IsValid                         : True

Get-Outlookprovider:

Name                          Server                        CertPrincipalName             TTL
----                          ------                        -----------------             ---
EXCH                                                                                      1
EXPR                                                                                      1
WEB                                                                                       1

Get-exchangecertificate:

Thumbprint                                Services   Subject
----------                                --------   -------
3284885789CD27601993A0360EF13BE12A8B76DE  IP.WS.     CN=remote.bsplastics.co.uk
F07A9386B08758ECFD385A14D4E6AF7EB96FE828  IP..S.     CN=remote.bsplastics.co.uk
83467045445162C800A72D15E637DB3A82F43533  IP..S.     CN=remote.bsplastics.co.uk
402D22B0D0FBEA2352DF685D0DBC8981C72BD9CA  IP..S.     CN=remote.bsplastics.co.uk
A3A329365A1F931FDEE1651E6728F6A63733E24F  IP....     CN=BSP-SBS-01.bsp.local
550168A96B08CEAAA0AB16015677E4080F3BC3F2  IP..S.     CN=remote.bsplastics.co.uk
1CD9635DE096FD55284772C57AEC8A36A8E2E7F4  ...WS.     CN=remote.bsplastics.co.uk, OU=InstantSSL, O=BS Motors ltd, STR...
E9085EE06D565CCFFB38F63487E609288F0057AE  IP..S.     CN=remote.bsplastics.co.uk
C8A9FB5069DF253BA2B12D98C032218D095B53B5  ......     CN=WMSvc-IAN-P6O0CPUFQ42
5DF4C6DF5EB127D427663D44015CBA64390179E4  IP..S.     CN=Sites
20405B5B52A4B1F82943C45987693D459C35FA17  ......     CN=bsp-BSP-SBS-01-CA
0
it_saigeDeveloperCommented:
Ok here are the settings that I tried (I dont have an account so I cannot authenticate).

In Email Account settings:
1.  Chose to manually configure server settings - Chose Microsoft Exchange or compatible service.
2.  Put remote.bsplastics.co.uk in the server line.  (you can choose to either use Exchange Cached Mode or not, if the machine is remote, I would choose to use Exchange Cached Mode.)
3.  Put in the user name and hit more settings (do not hit check name).
4.  In more settings, select the connection tab.
5.  Select 'Connect to Microsoft Exchange using HTTP' and click Exchange Proxy Settings
6.  In the 'Use this URL to connect to my proxy server for Exchange' put, remote.bsplastics.co.uk
7.  Uncheck 'Connect using SSL only' checked
8.  Change the proxy authentication settings to Basic.
9.  Press Ok.
10.  Press Ok.
11.  Press Next.  You will be prompted for the username and password.

-saige-
0
Stuart SmithTechnical Director Author Commented:
Hi Saige,

Still no luck, I type the password in and it just keeps going in a loop and doesn't accept the password.

I have attached a screenshot of the message that I got after being unsuccessful.
0
Stuart SmithTechnical Director Author Commented:
Any ideas on what this could be? I'm completely stuck for ideas on what to do.
0
it_saigeDeveloperCommented:
Sorry CDSFIX, busy day yesterday.

Ok I just reread through the comments and saw an entry that I had overlooked.  You mentioned that this is using POP3?  If that is the case then it is not about OutlookAnywhere.  Rather, it is about the ports and such that you have open for POP3 and SMTP (if the user will be sending email through your exchange server).

And according to mxtoolbox.com, it looks as if you have 110 open as your POP3 port.

So if this is truly supposed to be a pop3 setup, lets scratch the notion of using RPC over HTTP/s and troubleshoot this from a pop3 perspective.

To configure them to use their POP3 email,

In Email Account settings:
1.  Choose E-mail Account and click Next.
2.  Choose to manually configured server settings and click Next.
3.  Choose Internet E-mail and click Next.
4.  Fill in the users information - name, email address, user name and password.  For the Account type leave it as POP3, enter in the external address for your incomming and outgoing mail server - i.e. - remote.bsplastics.co.uk.
5.  Just guessing here, but you probably want to authenticate your SMTP connection, click on More Settings
6.  Select the outgoing server tab.
7.  Check the box that states, 'My outgoing server (SMTP) requires authentication'.  [Again just guessing but we can probably leave it at the default values once the box is checked.]
8.  Click 'Ok'.
9.  Click on test account settings and verify that both tests (incomming and outgoing) succeed.

-saige-
0
Stuart SmithTechnical Director Author Commented:
Apologies for not getting back sooner Saige I was on annual leave on Friday, I will attempt the above steps now and inform you of the outcome.

Kind Regards
0
Stuart SmithTechnical Director Author Commented:
Saige I set that up however when I press "Test account settings" I'm getting the password pop up again!!!!! I KNOW the password is correct as well.

When we configure it as an exchange account it normally works??
0
it_saigeDeveloperCommented:
When you entered the username, did you use:

domain\username

username@domain

-or-

username

If you have not done so as of yet, I would enable POP3 logging so that they can give us a better idea as to what the hang-up is.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26952460.html

http://tutorial.programming4.us/windows_server/Exchange-Server-2010---Managing-Logging-(part-1)---Managing-Connectivity-Logging---Managing-Protocol-Logging.aspx

-saige-
0
Stuart SmithTechnical Director Author Commented:
Hi Saige,

Please see some of the information from the POP3 log. If you need anything else please let me know.

2014-10-01T10:46:18.526Z,00000000000000FD,0,192.168.1.2:110,192.168.1.2:44672,,-2147483648,0,51,OpenSession,,
2014-10-01T10:46:18.545Z,00000000000000FD,1,192.168.1.2:110,192.168.1.2:44672,,0,4,61,quit,,R=ok
2014-10-01T10:51:19.014Z,00000000000000FE,0,192.168.1.2:110,192.168.1.2:44851,,-2147483648,0,51,OpenSession,,
2014-10-01T10:51:19.014Z,00000000000000FE,1,192.168.1.2:110,192.168.1.2:44851,,0,4,61,quit,,R=ok
2014-10-01T10:56:19.878Z,00000000000000FF,0,192.168.1.2:110,192.168.1.2:44991,,-2147483648,0,51,OpenSession,,
2014-10-01T10:56:19.898Z,00000000000000FF,1,192.168.1.2:110,192.168.1.2:44991,,0,4,61,quit,,R=ok
2014-10-01T11:01:19.981Z,0000000000000100,0,192.168.1.2:110,192.168.1.2:35519,,-2147483648,0,51,OpenSession,,
2014-10-01T11:01:20.028Z,0000000000000100,1,192.168.1.2:110,192.168.1.2:35519,,0,4,61,quit,,R=ok
2014-10-01T11:06:20.066Z,0000000000000101,0,192.168.1.2:110,192.168.1.2:35795,,-2147483648,0,51,OpenSession,,
2014-10-01T11:06:20.067Z,0000000000000101,1,192.168.1.2:110,192.168.1.2:35795,,0,4,61,quit,,R=ok
2014-10-01T11:11:20.195Z,0000000000000102,0,192.168.1.2:110,192.168.1.2:36007,,-2147483648,0,51,OpenSession,,
2014-10-01T11:11:20.196Z,0000000000000102,1,192.168.1.2:110,192.168.1.2:36007,,0,4,61,quit,,R=ok
2014-10-01T11:16:20.319Z,0000000000000103,0,192.168.1.2:110,192.168.1.2:56057,,-2147483648,0,51,OpenSession,,
2014-10-01T11:16:20.319Z,0000000000000103,1,192.168.1.2:110,192.168.1.2:56057,,0,4,61,quit,,R=ok
2014-10-01T11:21:20.365Z,0000000000000104,0,192.168.1.2:110,192.168.1.2:56215,,-2147483648,0,51,OpenSession,,
2014-10-01T11:21:20.383Z,0000000000000104,1,192.168.1.2:110,192.168.1.2:56215,,0,4,61,quit,,R=ok
0
it_saigeDeveloperCommented:
Try running this commandlet on your Exchange 2010 CAS Server:

Set-PopSettings -LoginType PlainTextLogin

-saige-
0
it_saigeDeveloperCommented:
Also what Roll-Up do you have installed on your Exchange server?

-saige-
0
Stuart SmithTechnical Director Author Commented:
Hi Saige I believe it's Roll-up 8. I have ran that command now shall I attempt to setup the emails again?
0
it_saigeDeveloperCommented:
Did you restart the POP3 Service?  I believe I forgot to mention that you needed to do that after running the cmdlet.

-saige-
0
Stuart SmithTechnical Director Author Commented:
Hi Saige,

Just restarted the POP3 service.
0
it_saigeDeveloperCommented:
Awsome.  Try it now.

Went from getting this error in my telnet session:

+OK The Microsoft Exchange POP3 service is ready.
user testuser
-ERR Command is not valid in this state

To this (potential success???):

+OK The Microsoft Exchange POP3 service is ready.
usertestuser
+OK

-saige-
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Stuart SmithTechnical Director Author Commented:
Saige!

I set it up as a pop3 account and it worked!!!

Thank you so much for all of your help we finally got there.
0
it_saigeDeveloperCommented:
Awsome, glad it is all sorted out.  Now, even though you can use your own opinion in this, me personally, I would disable POP3 logging.

http://exchangeserverpro.com/dont-leave-popimap-protocol-logging-enabled/

-saige-
0
Stuart SmithTechnical Director Author Commented:
Sorry we have another problem! I'm getting the error 5.7.1 unable to relay?

Any help with this?
0
Stuart SmithTechnical Director Author Commented:
Hi Saige,

Thanks for getting back to me.

Bs-motors is an accepted domain yes.
0
it_saigeDeveloperCommented:
Did you walk through that EE article to see if anything was amiss in your configuration?

-saige-
0
Stuart SmithTechnical Director Author Commented:
Saige all of that is configured correctly for the company. All is working as required.
0
Stuart SmithTechnical Director Author Commented:
Well apart from this bounce back. Still experiencing the issue.
0
Stuart SmithTechnical Director Author Commented:
I have configured a new thread for this issue. Thanks Saige.
0
it_saigeDeveloperCommented:
Sorry that I have not been able to get back to you on this.  Dealing with QA on a project that I have to complete this week.  I'll look for your other topic and assist in any way I can.

-saige-
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.