Server 2012 R2 Network Keeps Dropping with Hyper-V Installed

Setting up a new Hyper-V Server and I am running into an issue with the network connections.

12 NIcs all Broadcom NetExtreme Nics
HP Proliant DL560 Gen 8

I have the NICs separated in 4 teams using server 2012 r2 teaming
the OS team is currently only one enabled.
We are using IP4 only.

With Hyper-V not installed I am able to assign a static IP to the Teamed Nic connect to the internet ping resources etc...
When i install the hyper-v role thats when things get messy.  The NIc will connect for 30 seconds then the network will change from domain network to Public it will claim issues with the gateway and the DNS servers will not connect. All cables are connected properly and there are no issues with the switches as i have 20 plus other servers connected without any problems.  Looking for ideas to fix these network issues so i can continue configuring my VMs
AFRITSupportAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Broadcom strikes again. Make sure you have the latest drivers and NIC firmware. Disable TOE. If these are not 10G NICs, disable VMQ as well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AFRITSupportAuthor Commented:
awesome disabling VMQ did the trick that i will test and see if i need to disable TOE, unless you reccomend disabling TOE anyway and if i do should it be both ipv4 and ipv6?
0
Cliff GaliherCommented:
You'll get better performance with TOE disabled. Yes to disabling it on both v4 and v6.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

AFRITSupportAuthor Commented:
also should i disable the toe and vmq on the teams also?
0
Cliff GaliherCommented:
No need. The tam is a virtual adapter and both TOE and VMQ are physical constructs. The team will abide by the underlying settings on the physical adapters.
0
AFRITSupportAuthor Commented:
ok what about disabling the toe for ipv4 and ipv6
0
Cliff GaliherCommented:
I answered that above. Yes to both.
0
AFRITSupportAuthor Commented:
i disabled toe for ipv4 but left ipv6 it looks like the same issues are occuring again.
0
AFRITSupportAuthor Commented:
i will try this now and let you know
0
AFRITSupportAuthor Commented:
it still appears to be having the same issue and loses connectivity. not sure what else to do.
0
AFRITSupportAuthor Commented:
OK as an update i believe i resolved the issue thanks to some research and your method. I downloaded the latest drivers from HP which is the same version on the broadcom site and also updated the firmware of the NICs.  This changed the adapters to HP NICs rather then broadcom. Now when i checked the configuration settings by default now the TOE and VMQ is disabled. Everything seems to be working as it should at the moment.
0
AFRITSupportAuthor Commented:
Figured out there was more than just disabling configuration settings
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.