Solved

IP ADDR

Posted on 2014-09-20
14
802 Views
Last Modified: 2014-09-24
I tried to change to a static IP address from working DHCP model. When I do a network restart I get the following:

service network restart

Restarting network (via systemctl):  Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details.


When I look for details:

Failed to start LSB: Bring up/down networking.

In my IP settings I have:

TYPE=Ethernet
BOOTPROTO=static
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=eno16777736
UUID=a68ce778-9b60-4ec5-a296-eb9ec2fe471a
ONBOOT=yes
HWADDR=00:0C:29:92:73:39
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPADDR=192.168.0.136
NETMASK=255.255.255.0
GATEWAY=192.168.0.1

If I reboot ... seems like I can SSH so somehow its getting the network IP right.
0
Comment
Question by:Starquest321
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 4
  • +1
14 Comments
 
LVL 15

Assisted Solution

by:Insoftservice
Insoftservice earned 222 total points
ID: 40334488
What is the issue . Did not got your question.
i hope your network is working right.
If no you could even neat
0
 

Author Comment

by:Starquest321
ID: 40334491
When I issue the command:

service network restart

I get the error:

Failed to start LSB: Bring up/down networking.
0
 
LVL 29

Assisted Solution

by:Jan Springer
Jan Springer earned 223 total points
ID: 40334503
This should be the first line in your config file:

DEVICE="eth0"

Change it to what your device should be called (ifconfig)

Your BOOTPROTO should = none

And is you have Network Manager installed:

NM_CONTROLLED="no"
0
Increase Agility with Enabled Toolchains

Connect your existing build, deployment, management, monitoring, and collaboration platforms. From Puppet to Chef, HipChat to Slack, ServiceNow to JIRA, Splunk to New Relic and beyond, hand off data between systems to engage the right people.

Connect with xMatters.

 

Author Comment

by:Starquest321
ID: 40334512
Now I updated:

Still error:


DEVICE="eno16777736"
TYPE=Ethernet
BOOTPROTO=NONE
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=eno16777736
UUID=a68ce778-9b60-4ec5-a296-eb9ec2fe471a
ONBOOT=yes
HWADDR=00:0C:29:92:73:39
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPADDR=192.168.0.136
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
NM_CONTROLLED="no"
0
 
LVL 15

Assisted Solution

by:Insoftservice
Insoftservice earned 222 total points
ID: 40334517
DEVICE="eno16777736"
to DEVICE=eth0

use neat if you are using gui mode.

cat /etc/sysconfig/network-scripts/ifcfg-eth0
0
 
LVL 29

Accepted Solution

by:
Jan Springer earned 223 total points
ID: 40334537
if you do "ifconfig", it will show you your devices by name.
0
 

Author Comment

by:Starquest321
ID: 40334556
My device name is eno16777736 . . .so how can I just change to eno0?
Don't I need some other setup?

 ifconfig
eno16777736: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.136  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fdbc:f108:fdb1:0:20c:29ff:fe95:4e17  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::20c:29ff:fe95:4e17  prefixlen 64  scopeid 0x20<link>
        ether 00:0c:29:95:4e:17  txqueuelen 1000  (Ethernet)
        RX packets 5101  bytes 2403674 (2.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3489  bytes 628597 (613.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 8  bytes 660 (660.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 660 (660.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
0
 
LVL 29

Assisted Solution

by:Jan Springer
Jan Springer earned 223 total points
ID: 40334566
No, if 'ifconfig' picks that up then that's what you should use.

When you make the final changes:

ifdown eno16777736

and then:

ifup eno16777736

Check /var/log/messages for any errors.
0
 
LVL 15

Assisted Solution

by:Insoftservice
Insoftservice earned 222 total points
ID: 40334570
I hope NetworkManager  is enabled

systemctl status NetworkManager.service

ps aux | grep -I net   # will probably find NetworkManager still running.
chkconfig NetworkManager off

OR

systemctl stop NetworkManager.service

systemctl disable NetworkManager.service

systemctl restart network.service

systemctl enable network.service
systemctl NetworkManager disable
0
 

Author Comment

by:Starquest321
ID: 40334588
I followed this:
I hope NetworkManager  is enabled

systemctl status NetworkManager.service

ps aux | grep -I net   # will probably find NetworkManager still running.
chkconfig NetworkManager off

Then I did:


ifdown eno16777736

and then:

ifup eno16777736

Now I messed everything up:

I get on the ifup command:

The device eno16777736 has a different MAC address than expected, ignoring.

And I cannot SSH....

Urgent help
0
 

Author Comment

by:Starquest321
ID: 40334604
This command messed me up:

chkconfig NetworkManager off

I had to turn it back on and revert changes...
But I am still on dynmic
0
 
LVL 29

Assisted Solution

by:Jan Springer
Jan Springer earned 223 total points
ID: 40334627
make sure that the mac address listed for the device (via ifconfig) is the same mac address listed in your file.

so, turn NM off, update your ifcfg-eno* file and ifdown/ifup the interface.
0
 
LVL 15

Assisted Solution

by:Insoftservice
Insoftservice earned 222 total points
ID: 40334878
I mean to say that if network manager is enabled and it would not allow to connect.
After disabling your NM configure your file again and restart the service.
I thought you might have missed the point of NM and thats the reason i did not told to configure it again
0
 
LVL 62

Assisted Solution

by:gheist
gheist earned 55 total points
ID: 40335028
Why dont you set static DHCP reservation?

Minimal config file should look like this:
DEVICE="eno16777736"
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.0.136
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
BROADCAST=192.168.0.255
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question