Solved

Enable logoff only

Posted on 2014-09-20
12
186 Views
Last Modified: 2014-09-21
My client has a Windows Server 2008 R2 Enterprise that user logon to as a Terminal Server, we would like to only allow logoff as the users seem to make the mistake, on repeated occasions, to restart the remote computer instead of their own.
Is there a way that when the user clicks on Start the only option is Logoff
Thanks
Jeannie
0
Comment
Question by:data-informatique
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
  • +1
12 Comments
 
LVL 21

Expert Comment

by:CompProbSolv
ID: 40334579
I have not actually used this, but this link will show you how to disable Shutdown using a Group Policy:
http://www.petenetlive.com/KB/Article/0000499.htm
0
 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40334640
IME, ordinary users should not be offered the choice to shutdown or restart the TS/RDS server.  Can you verify the users have no admin privileges?
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40334675
Hi,

In our Citrix environment we have this policy set and it ensure users can only log off and not shutdown/restart the servers.

User Config>Admin Templates>Start Menu and Taskbar

If that doesn't work let me know and I will have another check of the GPO we have set.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:data-informatique
ID: 40335187
to answer Larry, the users have admin privileges because they are required to run the program that they use on the remote server
As for Roshan, where do I find "user config"
Thanks
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40335195
Its in the group policy management console when you go to create a new policy. Usually the group policy management console is found on the domain controllers.
0
 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40335208
Ask your programmer exactly what folders /files need admin rights and give the users full control of those.  Full admin for folks that can't remember to NOT turn off the RDS server is just asking for future trouble.
0
 
LVL 13

Expert Comment

by:Rizzle
ID: 40335245
Users should never have admin privileges in a corporate environment! That breaks the point of giving users enough privileges to do their job and not too much so they can do damage.

I agree with Larry completely! You need to carry out an evaluation of the application and the privileges it requires as for any environment if users need admin rights to run anything then it can't be fit for purpose/use.
0
 

Author Comment

by:data-informatique
ID: 40335542
You are both right, however, until I talk to the app's programmer, this is how far I have gotten:
- Server Manager
- Features
- Group Policy Management
- Forest
- Domain
- Name of the domain

I am looking for User Config>Admin Templates>Start Menu and Taskbar but cannot seem to find it, am I looking in the right location

Thanks
0
 
LVL 13

Accepted Solution

by:
Rizzle earned 500 total points
ID: 40335551
Click on group policy management the right click on the ou where the users are in and then select create new gpo and link it here. Then you should see user configuration.
0
 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40335556
I was going to say "change apps" if you could not get this narrowed down, but I figured it would be obvious and expensive.  Best to get the programmer to come into the 21st century and change his code.  Even quickbooks no longer requires full admin privileges.
0
 

Author Comment

by:data-informatique
ID: 40335558
I right-clicked on the ou, I picked the "create a new GOP in this domain, and link it here...", I gave it a name but the only thing that happens is that Group Policy Modeling appears in the tree.
I am new to this, so I am not quite sure how to create the group policy to only retain logoff
Thank you for your help
Jeannie
0
 

Author Closing Comment

by:data-informatique
ID: 40335652
I found what I was looking for, thank you for your help
I will definitely talk to the programmer on Monday
Thank you again
Jeannie
0

Featured Post

ScreenConnect 6.0 Free Trial

Explore all the enhancements in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI, app configurations and chat acknowledgement to improve customer engagement!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

OfficeMate Freezes on login or does not load after login credentials are input.
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question