Solved

Problem access Citrix web interface PS 4.5 with Mac OS X 10.7 client ?

Posted on 2014-09-22
12
281 Views
Last Modified: 2014-11-17
Hi everybody,
I've got a problem with the web interface on my Citrix PS 4.5 server (farm with 3 servers).
When people try to join the web interface (over IPSEC vpn), the page does not load. The browser looks for the page but never displayed. This happens with the Mac OS X 10.7 clients (safari, firefox, chrome - the same). Is there any issue with this type of configuration ? Thank you.
0
Comment
Question by:P6FER
  • 7
  • 5
12 Comments
 
LVL 23

Expert Comment

by:rhandels
ID: 40336298
Maybe i'm not reading the question correctly but what are you trying to do? Connecting to the website using the Safari browser? Or are you trying to use the Citrix Receiver agent? If the latter one is the case you need to type in the service URL and not the website URL. With WI this is https://www.mydomain.com/Citrix/PNAgent/config/xml.

Otherwise, is it possible to connect to other internal servers??
0
 

Author Comment

by:P6FER
ID: 40336313
I'm trying to connect to the published desktop via the internal url via http://local_citrix_srv/Citrix/AccessPlatform/auth/login.aspx and a browser on a macbook with os X 10.7. We don't connect via an external IP but with a cisco vpn and then the internal IP.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 40336316
Normally you would need to connect to HTTPS, not HTTP because of security reasons. Also, if you want to startup a session HTTPS is required.

And what happens if you just type in https://local.citrix.srv?? Normally there is no need to add the other stuff behind the URL if configured correctly.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:P6FER
ID: 40336322
No we don't use ssl. It works very well otherwise but not from outside with the vpn and a 10.7 mac os x device.
If I type in local_citrix_srv I'em redirected to http://local_citrix_srv/Citrix/AccessPlatform/auth/login.aspx , then I juste have to authenticate via the AD credentials and then click to the green button to launch the desktop.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 40336679
So all other devices do work when browsing to the Citerix Web Interface site and not when using MAc?? I must say i never heard of that before.. You did install the Mac OS receiver on the machines??
0
 

Author Comment

by:P6FER
ID: 40336686
I know it sounds really crazy ... But I noticed this anomaly on 3 computers so far, all were mac's ... Latest receiver are installed on those computers.
0
 
LVL 23

Expert Comment

by:rhandels
ID: 40336717
Could it be that you need to configure mac's to use an aspx file? Sounds quite strange cause we used the WI (although it was the WI shipped with XA 6.5 ) with macs, Ipad's, Iphones and all the likes..
0
 

Author Comment

by:P6FER
ID: 40356476
I don't know how to configure a mac to use an aspx file.. With older version of mac osx we don't have this problem. No problem with MS systems (xp, vista, 7, 8).
0
 
LVL 23

Expert Comment

by:rhandels
ID: 40356486
I'm afraid i'm at a loss.. No idea why it it isn't working.. It is not browser related as you tested multiple browsers.
Could it be a networking issue? Are you able to ping the actual server by it's FQDN?? So local.citrix.srv?? Do you get a successful ping attempt back? If not there is some sort of configuration error in the networking area which has got nothing to do with Citrix.
0
 

Author Comment

by:P6FER
ID: 40356494
I can ping the server IP and FQDN with success, I try with almost all the browser I've found (Safari, Chrome, FF etc).
Ok no problem ! To be continued..
0
 

Accepted Solution

by:
P6FER earned 0 total points
ID: 40437514
After many attemps, it seems that you have to delete any citrix receiver, reboot the mac, reinstall the receiver, reboot again, and then do the Mac Os X update, reboot and that's it.
0
 

Author Closing Comment

by:P6FER
ID: 40446848
That's the way I figure out.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We could spend the next millennium discussing the differences of the Mac and Windows platforms. The next century will continue to have fanatics on both side of the equation and neither side will win the war. However, that’s not why we are here. W…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question