Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Forwarding email using exchange transport rule to external email address

Posted on 2014-09-22
12
Medium Priority
?
1,941 Views
Last Modified: 2014-09-23
Need:
We have a support email account that receives emails from customers during the day.
at night we need those emails forwarded to an answering service.

Solution used:
We set up a transport rule that is enabled and disabled by widows task manager at appropriate times.
this transport rule watches for emails to support@company.com then "copies" that email to the external email for the answering service.  Then at the appropriate time the windows task manager disables the transport rule in the morning.

Problem:
When Exchange "copies" the email it actually sends it as the original sender, this causes any mail server set up with proper SPF record to refuse it because it looks like we are sending an email for their domain from an unauthorized mail server.

Anyone have any idea how to get around this to achive the same results for having a rule work for specific time frame and forwarding the email to outside email with out it sending the email as the original email sender.

Example:

Client user@abc.com sends us an email to support@company.com after 5pm (transport rule is active at this time)
transport rule copies and sends email to answering service at support@answeringservice.com the "from address" of this email is maintained as user@abc.com so the receiving email servers checks spf and finds that it does not match since its comming from company.com server not abc.com.

Configuration Summary:
Afterhours to Answer1
Identity: 'Afterhours to Answer1'
Name: 'Afterhours to Answer1'
Comments: 'Copy Answer1 during off business hours'

any help would be appreciated.
0
Comment
Question by:Nick Krapf
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
12 Comments
 
LVL 16

Accepted Solution

by:
Joshua Grantom earned 2000 total points
ID: 40336758
Create 2 different scheduled tasks on your Exchange server with these 2 exchange shell scripts

First One starts at 5:00 pm

Set-Mailbox support@company.com -ForwardingSMTPAddress answeringservice@company.com -DeliverToMailboxAndForward $true

Open in new window


Second One at 8:00 am

Set-Mailbox support@company.com -ForwardingSMTPAddress $null -DeliverToMailboxAndForward $false

Open in new window

0
 

Author Comment

by:Nick Krapf
ID: 40336829
Thank you for your reply.
So will that then truly forward the message as support@company.com?
because right now using the copy transport rule it sends it as user@abc.com
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40336835
yes it should send as support@company,com because it is actually forwarding the message similar to a client. It should show the message subject as FW: as well.
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:Nick Krapf
ID: 40337043
ok thanks we will test this method out.
0
 

Author Comment

by:Nick Krapf
ID: 40337708
when running the first command we get
WARNING: The command completed successfully but no settings of 'DOMAINNAME.local/Users/USERNAME' have been modified.
0
 

Author Comment

by:Nick Krapf
ID: 40337718
testing seems to be working though
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40337720
you are running this in exchange management shell?
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40337756
That error usually shows if you try to update a field to the exact same thing and powershell detects that there are no changes. Did you run it manually or by scheduled task?
0
 

Author Comment

by:Nick Krapf
ID: 40337765
running commands from management shell

since we want to test initially.
0
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40337768
okay, Ive never had a warning show up like that but you can add -verbose to get advanced logging. The warning should be disregarded I believe.
0
 

Author Comment

by:Nick Krapf
ID: 40337784
seems to be working .. will disregard the warnings
will proceed to set up tasks.
0
 

Author Closing Comment

by:Nick Krapf
ID: 40339377
just make sure you set up your task with elevated permissions.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New style of hardware planning for Microsoft Exchange server.
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question