Solved

SharePoint and Internet Explorer

Posted on 2014-09-22
6
262 Views
Last Modified: 2014-11-19
I have a SharePoint 2010 portal that will not open in Internet Explorer 9 on one desktop, but will open in Firefox and Chrome.  On another system, with Internet Explorer 8 the SharePoint portal will open.

When I say open I mean that I get the popup for authenticating.  I have ensured that pop-up blocker is disabled.  I have tried adding the site to the trusted sites tab in Internet options.

I am just not sure what to try next.  Any help would be greatly appreciated.
0
Comment
Question by:mounty95
  • 4
  • 2
6 Comments
 
LVL 31

Expert Comment

by:Jamie McAllister MVP
ID: 40336784
Temporary workaround from http://social.msdn.microsoft.com/Forums/en-US/90b3835c-6754-4bb6-9fd4-b74f16f236ff/sharepoint-2010-and-ie9-compatibility?forum=sharepointgeneralprevious

"OK, I've found the solution for this problem. It has to do with the IE9 document standards for the client's browser. If the document mode is set to IE 9 Standards the issue occurs, if you change the document mode to IE 8 Standards the issue no longer occurs. There is a way to force the page to load using IE 8 Standards in your aspx page. Add the following meta tag to your aspx page and the clients browser will load the page in IE 8 Standards document mode:

<meta http-equiv="X-UA-Compatible" content="IE=8"/>"
0
 
LVL 31

Expert Comment

by:Jamie McAllister MVP
ID: 40336790
0
 

Author Comment

by:mounty95
ID: 40336880
I made the change to the group policy Network security: LAN Manager authentication level per the article to no avail.  Did a restart of computer just for good measure and this had no effect.

Thanks for the reply.  This is quite perplexing.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 31

Expert Comment

by:Jamie McAllister MVP
ID: 40336962
If I turn anything else up I'll post it...
0
 

Author Comment

by:mounty95
ID: 40367022
So I solved my problem through trying to solve a completely different problem that another user was having.  It seems that there is a real compatibility issue between Internet Explorer 64 bit and Internet Explorer 32 bit.  Once I used Internet Explorer 32 bit which was already installed in Windows 7 under All Programs\Accessories\System Tools I was able to navigate to my new 2010 SharePoint Portal site.

The initial user issue that I am having that seems to also deal with the incompatibility issue is a user can not check out a document in a document library in Excel and make changes.  First Internet Explorer does not recognize the 2010 Office suite.  Next you can only open the document in Read Only and when saving save the document with the same name and overwrite the original.

Any insight into this debacle would be greatly appreciated.
0
 
LVL 31

Accepted Solution

by:
Jamie McAllister MVP earned 500 total points
ID: 40367851
Well I'm sorry I didn't mention the 32/64 bit issue. That's a constant issue we have in my own organization, and many support issues that users raise can be solved by making sure they're using the 32 bit browser.

In the end, we ensured that our standard Windows 7 build didn't include IE x64.

I hear this is being resolved in later versions, but not in my product at my level of patching.

We run into the issue of user not being able to edit Excel that I put together the following investigation cheat sheet for support;

Problems editing Excel sheets
1.      Confirm user has edit permissions
2.      Check that user is accessing G-Docs via Internet Explorer 9 x32 bit.
3.      Add G-Docs site to Trusted Sites list in IE.
Try any of the following:
•      In IE, go to options > connections > Lan settings, turn of "Automatically detect settings"
•      Make your SP site is a Trusted Site in IE
•      Add SP to the Trusted Locations in Office
•      Turn off all the Protected View options in the Office Trust Center
•      Delete the Office cache file:
c:\Users\\AppData\Local\Microsoft\Office\14.0\OfficeFileCache
If none of the above solutions work, check the file association:

In some cases the “XLSX” extension – file open reference is pointing to moc.exe rather than excel.exe.
 
This can be remedied by performing the following action –
 
Go to my computer – Tools (menu)– Folder Options
 
Click the File Types (Tab)
 
Find the file type XLSX
 
Click Advanced then open in the list, hit the edit button
 
Check “application used to perform action” for references to moc.exe (Microsoft Open XML Converter), if so delete the contents and insert the following –
“”C:\Program Files\Microsoft Office\Office14\EXCEL.EXE”” /e
 
Click ok, ok and close.


If all the above fails, sometimes a registry key change is needed, which must be performed with great care!

HKCU-Software-microsoft-office-12,0-internet

In there create dword value “OpenDocumentReadWriteWhileBrowsing” – value should be 1
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now