Solved

SonicWALL and Bonjour / Mac devices do not play well together...?

Posted on 2014-09-22
14
106 Views
Last Modified: 2016-06-07
Client needs some advanced protection from home office for HIPAA and other compliancy, A Sonicwall TZ 105 is installed and working great other then it is causing havoc with the internal Apple devices. We have had our techs spend many hours on this little -what-should-be-very-easy project but unfortunately the Mac devices dont make it so easy.

What has been done:

Have allowed DMS through Sonicwall. Tested it with all security services turned off. Reloaded firmware to factory default. And more...

Looking on the Internet this seems to be a known issue but not many people have solved it.

Also there is a new Time Capsule in place which "has to have the wireless turned on" for it to be operational, another great Apple innovation.  

Apple devices do not always show in Airplay utility and the backups from the Macbook to the time machine are not working consistently or at all.

Any help is appreciated.
0
Comment
Question by:Jason Kidman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
14 Comments
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 40337448
I don't believe Bonjour needs anything outside of the LAN you're trying to protect. Just block it on the firewall and don't log it. It only runs between LAN-connected devices for printer discovery, etc.

You shouldn't need the wireless on the Time Capsule as long as (duh) you have a wired connection to it. It doubles as a WiFi router but that's separate from the NAS functionality.

On the Airplay, you'd have to be more specific about the problems. But they may clear up if you turn off the WiFi on the time capsule, who knows.
0
 

Author Comment

by:Jason Kidman
ID: 40339439
We have tried all of that. Any other ideas?
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 40339661
Are you saying you turned off the WiFi on the time capsule? Have you tried just disconnecting the Sonicwall from the network, or powering it off, to see if the local stuff clears up again? That would at least isolate whether the problem is truly the Sonicwall.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Jason Kidman
ID: 40341878
We tried turning off wifi, it was one of the first things we did.

We also disconnected the SonicWALL completely, and that DID make everything work. So the SonicWALL is the issue
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 40342766
Are the devices connected directly to the Sonicwall, or is there another switch in between? I'm wondering the Sonicwall is doing some kind of inbound inspection on each port which could be avoided if there was another switch in between to handle the LAN connectivity.
0
 

Author Comment

by:Jason Kidman
ID: 40347265
I will check and get back to you on that last comment
0
 

Author Comment

by:Jason Kidman
ID: 40352765
The sonicwall is being used as a switch.  One wan and all the rest are LAN ports.  The only thing plugged into the any of the lan ports is the Time Capsule.
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 40353402
Then there must be some other switch which connects the other devices to the Sonicwall?  So, what if the Time Capsule is connected to the same switch as the other devices, and the Sonicwall just provides the WAN connectivity?
Sonicwall--LAN Switch--Everything else
                               |
                          Time Capsule

Or is there no other switch and the sonicwall is providing WiFi for everything else?
0
 

Author Comment

by:Jason Kidman
ID: 40353499
Actually that is a good question. Everything in the home office is wireless, except the hardwired time capsule.

Does that make sense?
0
 

Author Comment

by:Jason Kidman
ID: 40353503
Do you think the SonicWALL builtin Wireless (which has a reputation of being poor anyway) is the culprit
0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 500 total points
ID: 40353526
It could be. You could try using the Time Capsule for the wireless and see if it cleans up. That's pretty solid in my experience.
0
 

Author Comment

by:Jason Kidman
ID: 40361480
Update: No update as of now, we will be sending a tech to this client to troubleshoot. Will post update.
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Need a version of swift for windows 10 2 71
Mac Screenshot Resolution 9 258
Windows 2012 R2 Anywhere Access and PCI compliance 5 67
allow device through ASA 4 13
Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question