Email not going out in Exchange 2007

I have a client with a SBS 2008 exchange box at his jobsite and moved it to his ATT modem equipped home. I have setup a Netgear router behind the ATT modem (which is in pass-through) and have equipped the ports all from the other setup for mail, gre, rdp, etc,, I have the new outside IP embedded in the Netgear along with DNS, Gateway subnet, etc. The internal IP of the server is the same.

The internet, printers, and dns are working, but can't get mail to go out from Exchange 2007. I have run BPA on exchange, message tracking, and any other tools to see why it just sits in the queue including Fix my network. My submission queue shows 0 files, but the messages tab has 8 and increases when I try to add more to send out.  The queues are not suspended, local emails are listed as well as outside mails

Driving me batty, spending way to much time on this.
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pcdevCommented:
have you created a send connector?
0
Joshua GrantomSenior Systems AdministratorCommented:
AT&T may also be blocking port 25 going out on their network. They do this to reduce the risk of people setting up spam mail servers at home.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
I have an existing send connector, yes. I have not recreated one. I will call ATT to see if they are blocking 25.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

pcdevCommented:
In the powershell Check the port
Get-SendConnector | ft Id*,Sm*s,po*

if it's 25 then run this and change to another port such as 26
Set-SendConnector “OutboundMail” -port 26

restart the transport service and send mail
0
Joshua GrantomSenior Systems AdministratorCommented:
pcdev,

that may work but port 26 is usually used for encrypted smtp, the receiving mail servers will probably reject it anyway.
0
pcdevCommented:
Very true, Joshua, thanks for reminding me.

Other ports to try are 487 or 587
0
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
pcdev, what is "OutboundMail" name?
0
pcdevCommented:
The Value under "Identity" from running Get-SendConnector | ft Id*,Sm*s,po*
0
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
Im being told that ATT will not open port 25,, If I change the server port to another, what other things do I have to change?
0
pcdevCommented:
You shouldn't need to do anything other than tell you send connector to use another port other than 25.
Have you tried setting it yet? give it a try it won't hurt
0
Joshua GrantomSenior Systems AdministratorCommented:
One thing you do have to worry about is if ATT is also blocking port 25 for incoming.

Have you verified that you can receive mail?
0
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
I have changed it to 26 and 587 and it will not go.. Will try 2525 and see
0
pcdevCommented:
i think you do have to restart the transport services. if still no send then a full reboot
0
pcdevCommented:
Any news on this yet?
0
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
I tried 8 different ports, and it still says error 421 4.2.1 Unable to connect.. I think I will just move them to Office 365,, ATT will not open the port 25, but they are not alone either, lots of ISP providers won't
0
Kevin CaldwellOwner of RUseeingRed Tech SolutionsAuthor Commented:
Joshua was the one to point out that Home based ISP's block port 25, so I give him the points.. Thanks to all, The client was moved to cloud exchange.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.