[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1163
  • Last Modified:

Slow database connections on Windows 8.1

This is a strange one and not easy to explain, so please bear with me :)

I have 2 PC's that were recently upgraded from Windows 7 Pro to Windows 8.1 Pro, both machines are running Visual Studio 2013 and SQL Server Management Studio.

Either when stepping through code in VS that connects to a database (SQL Server or MySQL) or when connecting to a database in SSMS, the operation was quick (less than a second).

After upgrading, the above operations are taking between 5-10 seconds.

I've carried out the same operations on 3rd PC still running Windows 7 Pro and everything is fine (same versions of VS, SSMS and code).. so the common denominator here seems to be Windows 8.1

Has anyone any idea what's happening here and how to resolve?
0
BrianFord
Asked:
BrianFord
  • 3
  • 3
1 Solution
 
McKnifeCommented:
You leave out some details that are rather important:
-was this an inplace upgrade or a clean install? Same with clean, "naked" (no software) installs?
-drivers are updated?
-8.1 updated? All updates, even optional ones?
-have you uninstalled your AV software for a test?
-did you network benchmark the connection yet and compare it to a win7 benchmark? Use netio http://www.ars.de/ars/ars.nsf/docs/netio
0
 
BrianFordAuthor Commented:
One of the machines was upgraded from Win7 to Win 8 and then Win 8.1, the other was a clean install of Window 8, then upgraded to 8.1

As far as I can tell, all drivers are the latest

All updates (even optional) were applied to both machines

I haven't 'un-installed' my AV software but I did 'disable it' and it had no effect.

For further info: I am currently building an ASP.NET Web Site, when I run the web-site from Visual Studio on the dev PC (using a local IIS Express) the app is really slow accessing the database on a Win 2K8 server, when I 'publish' the web-site to the same Win 2K8 sever and access the site using IE, Chrome, or Safari running on the Dev PC, the site works great (database access is instant), hope that makes sense :)
0
 
McKnifeCommented:
Uninstall the AV and reboot. Disabling is nowhere next to uninstalling as it does not remove the filter drivers.
If that does not help, do the benchmark comparison. Also tell us if you used clean 8.1 systems (only install the OS, all updates and the minimum of software needed for the test).
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
BrianFordAuthor Commented:
Thanks

I did as you suggested and completely un-installed the AV and it did indeed resolve the issue, I guess I now need to figure out how to configure my AV to stop interfering :(
0
 
ExpertNotReallyCommented:
If your AV has a firewall make a firewall rule to allow connections to the ports you are using to connect to the database servers.
0
 
BrianFordAuthor Commented:
Thanks for your help

I'll need to get in touch with AV provider as the firewall is currently not enabled and I don't se anywhere to add the exclusions :(
0
 
McKnifeCommented:
It is no port configuration. Firewalls make ports accessible for hosts or not accessible. There's no option in them to "slow down this connection", so if it works, the port is open (no matter if slow or not).

But looking at the AV config is of course the right thing. Maybe the AV needs to be updated to the latest version or needs to be patched.
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now