Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Configure attachment size OWA Exchange 2013

Posted on 2014-09-23
7
Medium Priority
?
2,786 Views
Last Modified: 2014-09-24
I have recently installed an Exchange Server 2013.
I have setup in all Send and Receive connectors a maximum message size of 100MB, through the EAC.
That works fine for Outlook.

However, in OWA, when trying to attach anything larger than 5MB, I get:
"The following files weren't attached because adding them would cause the message to exceed the maximum size limit of 5 MB"

I found this article explaining how to change the message and attachment size limit for OWA, using notepad (really) to edit manually 27 (yes, 27!!) entries in a bunch of config files.
http://technet.microsoft.com/en-us/library/hh529949.aspx
I went thoroughly through all of them, changed them, and rechecked each one.
I ran a IISRESET after that.
I still have the problem.

I don't know where that '5MB' limit is coming from, but threre wasn't anything in the config files set to 5MB before the change (they were settings to 10MB, 35MB and 64MB, I think) so I'd guess this limit is coming from yet another location that I didn't find yet.
0
Comment
Question by:DFUYT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 16

Expert Comment

by:Joshua Grantom
ID: 40339757
Go to Exchange Management Shell, and type the following command:

Set-transportconfig -MaxSendSize: 100000

OWA does not know how to interpret Unlimited values.

or

Go into "Organizational Transport Settings" and change "Maximum receive message size" and "Maximum send message size" to 100 mb
1
 
LVL 12

Expert Comment

by:Vaseem Mohammed
ID: 40339823
run these cmdlets from Exchange management shell and see what results you get.
get-receiveconnector | foreach{$_ | select Name,Maxmessagesize}
get-sendconnector | foreach{$_ | select Name, MaxMessageSize}
get-transportconfig | select MaxReceiveSize, MaxSendSize
0
 

Author Comment

by:DFUYT
ID: 40339870
I'm sorry, I had already setup that limit, I wasn't clear about that.
I checked using
Get-TransportConfig | fl  
and this is the output:

AddressBookPolicyRoutingEnabled                             : False
AnonymousSenderToRecipientRatePerHour                       : 1800
ClearCategories                                             : True
ConvertDisclaimerWrapperToEml                               : False
DSNConversionMode                                           : UseExchangeDSNs
JournalArchivingEnabled                                     : False
ExternalDelayDsnEnabled                                     : True
ExternalDsnDefaultLanguage                                  :
ExternalDsnLanguageDetectionEnabled                         : True
ExternalDsnMaxMessageAttachSize                             : 10 MB (10,485,760 bytes)
ExternalDsnReportingAuthority                               :
ExternalDsnSendHtml                                         : True
ExternalPostmasterAddress                                   :
GenerateCopyOfDSNFor                                        : {}
HygieneSuite                                                : Standard
InternalDelayDsnEnabled                                     : True
InternalDsnDefaultLanguage                                  :
InternalDsnLanguageDetectionEnabled                         : True
InternalDsnMaxMessageAttachSize                             : 10 MB (10,485,760 bytes)
InternalDsnReportingAuthority                               :
InternalDsnSendHtml                                         : True
InternalSMTPServers                                         : {}
JournalingReportNdrTo                                       : <>
LegacyJournalingMigrationEnabled                            : False
LegacyArchiveJournalingEnabled                              : False
LegacyArchiveLiveJournalingEnabled                          : False
RedirectUnprovisionedUserMessagesForLegacyArchiveJournaling : False
RedirectDLMessagesForLegacyArchiveJournaling                : False
MaxDumpsterSizePerDatabase                                  : 18 MB (18,874,368 bytes)
MaxDumpsterTime                                             : 7.00:00:00
MaxReceiveSize                                              : 100 MB (104,857,600 bytes)
MaxRecipientEnvelopeLimit                                   : 500
MaxRetriesForLocalSiteShadow                                : 2
MaxRetriesForRemoteSiteShadow                               : 4
MaxSendSize                                                 : 100 MB (104,857,600 bytes)
MigrationEnabled                                            : False
OpenDomainRoutingEnabled                                    : False
RejectMessageOnShadowFailure                                : False
Rfc2231EncodingEnabled                                      : False
SafetyNetHoldTime                                           : 2.00:00:00
ShadowHeartbeatFrequency                                    : 00:02:00
ShadowMessageAutoDiscardInterval                            : 2.00:00:00
ShadowMessagePreferenceSetting                              : PreferRemote
ShadowRedundancyEnabled                                     : True
ShadowResubmitTimeSpan                                      : 03:00:00
SupervisionTags                                             : {Reject, Allow}
TLSReceiveDomainSecureList                                  : {}
TLSSendDomainSecureList                                     : {}
VerifySecureSubmitEnabled                                   : False
VoicemailJournalingEnabled                                  : True
HeaderPromotionModeSetting                                  : NoCreate
Xexch50Enabled                                              : True

Just in case, I also checked in "Organizational Transport Settings" and both "Maximum receive message size" and "Maximum send message size" showed up as 100 MB.

Just in case, I did another iisreset, but the problems continued.
I checked from IE, Chrome and Firefox, from 2 different computers.
I can attach things up to 5MB but when I go beyond that limit, either with one or the sum of attachments, I will get that error message.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:DFUYT
ID: 40339879
I ran all the commands suggested by :

get-receiveconnector | foreach{$_ | select Name,Maxmessagesize}
get-sendconnector | foreach{$_ | select Name, MaxMessageSize}
get-transportconfig | select MaxReceiveSize, MaxSendSize

and each value returned was 100MB
0
 
LVL 16

Accepted Solution

by:
Joshua Grantom earned 2000 total points
ID: 40339932
you need to restart the exchange server, not just IIS.

You may be able to get away with restarting the "Exchange Information Store" service instead of the entire machine.
1
 
LVL 12

Expert Comment

by:Vaseem Mohammed
ID: 40339938
The link that you refered http://technet.microsoft.com/en-us/library/hh529949.aspx under Outlook Web App section some of the size is mentioned in bytes and kilobytes, did you convert the value correctly?
0
 

Author Closing Comment

by:DFUYT
ID: 40341532
In the end, it was a stupid thing.
I had already made all changes needed, but a restart of the exchange server, instead of a iisreset, was needed.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
One-stop solution for Exchange Administrators to address all MS Exchange Server issues, which is known by the name of Stellar Exchange Toolkit.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question