?
Solved

MMC has detected an error in a snap in sbs 2008 wsus

Posted on 2014-09-23
17
Medium Priority
?
395 Views
Last Modified: 2016-02-13
Hi everyone,

I have an SBS 2008 R2 server in a small business which suddenly reported failed backups.
After a while I stopped the VSS service which then started the backups working again, but somewhat haphazardly.
BUT after stopping VSS service,  for some reason WSUS stopped working. I have tried to use the Microsoft Technet article referred to by some queries in EE, entitled "Repair Windows Update Server Services.  Latest update March 24 2009."
1) I cant delete the old WSUS directory because it reports that the folder is being used by another program.
2) If I cut and paste the command line command in an elevated cmd prompt. it seems to do something for about 5 secs then stop. Not the 10 mins referred to in the article.
3) if I  then try to open the windows server update services plug in, I get the "MMC has detected an error in the snap in."  
I am now at my wit's end and need some help desperately.  
BTW: I generally do the administrative  work remotely via VPN and remote desktop, because I am some distance away from the server.
Could this fact affect the ability to delete files etc?
Because there appear to be multiple problems with both the backup and the WSUS, I presume the SQL database is corrupt or something equally sinister, so how do I go back to first principles and solve the problem?

Please help.....
Kind regards
Chris
0
Comment
Question by:krisnparker
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 3
17 Comments
 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40341848
From your sequence it seems all you really need to do is to repair the VSS writers and restart them, then the WSUS issue would no longer be an issue?

Besides stopping the VSS have you done anything else to remediate?

There are a bazillion articles already on repairing VSS, including many on this forum.  Have you looked at/tried any of them?  Start by "vssadmin list writers" from an elevated command prompt.  Check for any error conditions and let us know.
0
 

Author Comment

by:krisnparker
ID: 40342919
I have done the VSS admin list writers in an elevated cmd, and the last time I did it there were no errors. I will do it again with the service started and stopped. The only other remediation I did was to try to delete the WSUS folder as specified in the article by MICROSOFT.
Thanks for at least a response!
Much appreciated.
0
 

Author Comment

by:krisnparker
ID: 40342965
Please see the VSSadmin list  writers list attached. as you can see there's no errors. I would like to change the points on the question, but can't see how to?

Help...
vss-admin-list.txt
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40344980
So you stopped the VSS services in an attempt to remediate backup failures?  What prompted you do to so?  Were there any clues in the backup history or in the event logs?
0
 

Author Comment

by:krisnparker
ID: 40345108
It was one of the temporary solutions proposed in this forum, just to get backups happening, which was my main concern. Then the server reported that WSUS wasn't working. It seemed to be working on the server but not the clients. There was a continual failure on the server to update to the latest WSUS (v3??), which is what led me to check the client updates and saw the WSUS problem.  

Thanks a lot for your help. I feel a bit helpless being in a remote spot in Australia. The difference in time zones doesn't help.
0
 
LVL 22

Expert Comment

by:Larry Struckmeyer MVP
ID: 40347817
Because no one else is helping, I'm guessing the solution is not apparent from the information given.  I know it is not to me.  Can you please check your event viewer - windows logs for error conditions that might be relevant, then drill down to the details in the  applications and services logs and the others in the lower half?
Event-Viewer.JPG
0
 

Author Comment

by:krisnparker
ID: 40348253
Will do ASAP
0
 

Author Comment

by:krisnparker
ID: 40348313
I think you have got me to the problem. the solution is another issue.
It appears that the Database is full. See JPG attached.
I have searched for a way to fix it but none of the solutions seem to have the same configuration and tools as this server.
I have also attached a picture of the SQL programs on the server, and the configuration snap in.

I have little or no experience with SQL and would really appreciate a step by step as to how to fix the data base.

Kind regards

Chris
eventlog.jpg
0
 

Author Comment

by:krisnparker
ID: 40348315
0
 

Author Comment

by:krisnparker
ID: 40384004
I have actually mangaged to fix it myself.
What I did was through a difficult process to delete a number of entries in the Database. I found that on one day for an hour, a number of the same errors occurred. About 2.5 gig worth. Considering that the whole Database was allowed a Max of 4 gig, it swamped the Database and it basically stopped working. After deleting I then found that a whole bunch of permissions were wrong and spent an hour setting the permissions as they should be.
I think from memory the date these errors occurred was the 16/05/2014. They never occurred again after that. I cannot remember the error code, but 3302 rings a bell!
I still have a slight problem with the WSUS, but am in the process of reinstalling it. At least the add in works and the console and the server as a whole is stable.

I am a bit disappointed with the response from EE but it forced me to delve into the guts of SQL and I learned a lot!
0
 

Accepted Solution

by:
krisnparker earned 0 total points
ID: 40389974
i've just fixed WSUS. It required a re-installation of WSUS, but not via Control Panel. I uninstalled it by running the WSUS Exe file from the install disk, which gave the option of doing a FULL uninstall.  A few regedits and deletions, and the re install went perfectly.

Green lights everywhere!
0
 
LVL 35

Expert Comment

by:Seth Simmons
ID: 40854398
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Always backup Domain, SYSVOL etc.using processes according to Microsoft Best Practices. This is meant as a disaster recovery process for small environments that did not implement backup processes and did not run a secondary domain controller that ne…
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question