?
Solved

linux mutt  does not send attachment

Posted on 2014-09-23
16
Medium Priority
?
227 Views
Last Modified: 2014-10-05
I am running Linux RH5.00 on a server
I  am using Mutt for outgoing emails sending invoices etc to customers
I have been using Mutt for years without problems for many year
Until I had a hard boot event
All of a sudden mutt is acting strange
I am regular emails without a problem.
I have a problem with attachments
I can not send any attachments above a file size of 2k
If does not produce an error but email does not arrive to its destination
your help is appreciated

thanks
Dory
0
Comment
Question by:dory550
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 5
16 Comments
 
LVL 6

Expert Comment

by:xeroxzerox
ID: 40340800
if you want to attach file .. you must have uuencode installed.
if uuencode installed then just try to send mail from it.
Syntax (uuencode reports.tar.gz reports.tar.gz | mailx -s "My Report" you@abc.com)
If you get any error then share it
Still i'm using heirloom-mailx.It's very easy to manage.you could try it in your R&D box machine.
0
 

Author Comment

by:dory550
ID: 40341243
xeroxzerox
Thanks for responding to my question
We have been using mutt for 5 years now, it is hardcoded into many of our programs and replacing it is  unfortunately not on the table.
I need to know what can cause mutt to have a restriction of 2k maximum per attachment
or how can a hard boot cause mutt to behave like that.
thanks
Dory
0
 
LVL 6

Expert Comment

by:xeroxzerox
ID: 40341285
Hi Dory,

I agree with you,can you send e-mail without attachment.
or run #postconf | grep message_size
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:dory550
ID: 40341315
xeroxzerox

Sending without an attachment is working fine
thanks
Dory
0
 

Author Comment

by:dory550
ID: 40341322
Is it possible to contact Red-Hat and create a support event (like msft ) and pay for it ?
Thanks
Dory
0
 

Author Comment

by:dory550
ID: 40341328
I checked the Red-hat website but did not find any indication that they do that
Dory
0
 
LVL 6

Expert Comment

by:xeroxzerox
ID: 40341356
It's not a big problem.
which MTA are you using?
have you tried  installing it again?
what is the output of #postconf | grep message_size
0
 

Author Comment

by:dory550
ID: 40341530
xeroxzerox
I followed your instruction and received "command not found" statement
Thanks again
Dory
0
 
LVL 6

Expert Comment

by:xeroxzerox
ID: 40342070
have you tried  installing it again?
0
 
LVL 30

Expert Comment

by:serialband
ID: 40342125
If the postconf command doesn't run for you, then you may not be running postfix.  Just to make sure, did you cut and past xeroxzerox's command without the #

postconf | grep message_size

If you don't have postfix, then are you using sendmail?  Check in sendmail.cf and change the message size

MaxMessageSize=1000000 - this is the maximum message size in bytes; by default there is no limit.
0
 

Author Comment

by:dory550
ID: 40343038
serialband
Thank you for helping out
I did exactly as you instructed (see attached)
But problem did not go away
I any ready for any other suggestion
thanks
Dory
ScreenShot.jpg
0
 

Author Comment

by:dory550
ID: 40343041
xeroxzerox
How do I go about installing it again
I guess you mean MUTT
Thanks
Dory
0
 

Author Comment

by:dory550
ID: 40343049
Serialband
By the way
I did not  find 'MaxMessageSize' entry in sendemail.cf
(maybe it was there but I didn't see it)
So I just added it
Dory
0
 
LVL 6

Accepted Solution

by:
xeroxzerox earned 2000 total points
ID: 40343203
it's easy.just do this step
[root@lenovo ~]# rpm -q mutt
mutt-1.5.20-2.20091214hg736b6a.el6.i686
[root@lenovo ~]# rpm -e mutt-1.5.20-2.20091214hg736b6a.el6.i686
[root@lenovo ~]# rpm -q mutt
package mutt is not installed.

For install mutt
[root@lenovo ~]# yum install mutt
0
 

Author Comment

by:dory550
ID: 40343932
xeroxzerox
It is a holiday here today
I will try that tomorrow
Thanks
Dory
0
 

Author Closing Comment

by:dory550
ID: 40361981
xeroxzerox
thank you for your help
Sory
0

Featured Post

Docker-Compose to Simplify Multi-Container Builds

Our veteran DevOps Author takes you through how to build a multi-container environment, managed with a single utility in order to simplify your deployments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question