Solved

Exchange certificate

Posted on 2014-09-24
20
144 Views
Last Modified: 2014-09-24
I have executed command new-exchangecertificate and allowed overwrite certificate which was expired, now my pop users cannot send email, returning them error "None of the authentication methods supported by this client are supported by your server"..

Could anyone please suggest the solution at earliest.
0
Comment
Question by:Adnan J Iqbal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 9
20 Comments
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341063
Are you using selfsigned certificate ? Run the command Get-Exchangecertificate on all CAS servers see the certificate status is showing as valid or invalid.
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341065
yes i am using self signed.i ran this command it is not showing status only showing services and subject
0
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 40341069
Try this:

Exch server Receive connector, Authentication tab

Transport Layer Security (TLS) --> enabled

Basic Authentication --> enabled with "Offer Basic auth only after TLS" enabled

Integrated Windows authentication --> enabled

OL client, POP3 profile

Incoming POP3 server --> port 995, SSL required

Outgoing SMTP server --> port 25, TLS encryption enabled

Outgoing mail server (SMTP) requires authentication enabled

SPA enabled

Thanks,
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:Adnan J Iqbal
ID: 40341075
Yes all these settings are as it is.
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341083
Run the command on Exchange : Get-ExchangeCertificate | fl
you will be able to see the status of the certificate.
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341085
i am receiving an error while enabling the certificate as well.."The term 'Enable-ExchangeCertificate-Thumbprint' is not recognized as a cmdlet,
 function, operable program, or script file. Verify the term and try again.
At line:1 char:38"
Also when i select TLS it works fine, but before creating new certificate it was working with encryption level :NONE
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341090
ok the status is valid
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341098
Enable-ExchangeCertificate -Thumbprint "Paste the certificate thumbprint here"
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341099
Same error
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341106
Did u paste the certificate thunmbprint?  See the attached screen shot to find out the thumbprint, while pasting it you will need to remove all the sapce.  Also make sure that you are running the command on CAS server.
Thumbprint.jpg
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341147
OK Done..Asked for services values, provided with IMAP,pop and SMTP but still with enctupted value with none sending is not working
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341151
Restart the transport services on HUB servers
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341152
Are you using third party services for incoming and Outgoing emails?
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341158
Restarted services, same error, what do you mean by third part services. some of my users are using pop account for email
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341160
like cloud services for Antispam, can you please send us the screen shot of the error.
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341168
No cloud services are used for anything. Please see attached
123.jpg
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 40341184
Is it configured via POP or configured as Exchange account.
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341189
POP
0
 
LVL 17

Accepted Solution

by:
Gaurav Singh earned 500 total points
ID: 40341199
0
 

Author Comment

by:Adnan J Iqbal
ID: 40341212
Ok it worked. i deleted and configured the account again.. thanks a lot.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article explains how to install and use the NTBackup utility that comes with Windows Server.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question