Solved

Allow big attachments to be received in Exchange 2010

Posted on 2014-09-24
9
60 Views
Last Modified: 2015-02-09
Client wants to receive large attachments because customers are trying to send huge things that they shouldn't, and it's easier to receive them than try to train the sender in good internet practices.

I compromised and said I'll allow up to 40MB attachments be received. This has been working for a long time.

Last week (sometime) it started rejecting everything over 10MB.

Everywhere I look, I see that 40MB was setup properly.

For Example:

[PS] C:\Windows\system32>get-transportconfig | fl maxreceivesize, maxsendsize


MaxReceiveSize : 40 MB (41,943,040 bytes)
MaxSendSize    : 40 MB (41,943,040 bytes)

Open in new window


and for the user in question:
[PS] C:\Windows\system32>get-mailbox  john | fl maxReceiveSize,MaxSendSize


MaxReceiveSize : 100 MB (104,857,600 bytes)
MaxSendSize    : 100 MB (104,857,600 bytes)

Open in new window


Even the best practices analyzer recognizes that it should be 40MB (and complains... as it should):

9-24-2014-12-51-36-PM.png
Yet, I am still getting bounces for things that are only 15MB:

Delivery to the following recipient failed permanently:

     john@theclient.com

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain theclient.com by office.theclient.com. [123.456.78.9].

The error that the other server returned was:
552 5.3.4 Message size exceeds fixed maximum message size

Open in new window


Where else should I be looking?
0
Comment
Question by:DrDamnit
9 Comments
 

Expert Comment

by:Roberto Oviedo
ID: 40342249
Hi good morning

The email you receive in a Edge or some antispam device, if you pass by some antispam check to verify that the configuration is not blocking the email.

You can also check the receive connector with this command

Get-ReceiveConnector  | fl

or

Get-ReceiveConnector | where {$_.PermissionGroups -like "*Anonymous*"} | fl


Greetings.
0
 
LVL 9

Expert Comment

by:Marshal Hubs
ID: 40343197
Anything in between Exchange Server and the outside world like a spam filter or firewall or any device between Exchange and the Internet could have a different limit set on it that could be the reason of your problem. This also includes your ISP. Also, check your WG SMTP-Proxy settings. Go into the proxy configuration editor and check the settings.
0
 
LVL 32

Author Comment

by:DrDamnit
ID: 40440515
Finally had the ability to swing back around to this.

The spam filter is not blocking it. The bounce messages specifically say that the exchange box is doing it.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 32

Author Comment

by:DrDamnit
ID: 40440518
It's not the ISP either.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 40442142
Hi Michael, did you check the Receive Connector as suggested above as there will be restrictions set on there too?

A useful guide for reference:

http://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html

Alan
0
 
LVL 16

Expert Comment

by:Rajitha Chimmani
ID: 40442785
You must contact the recipient domain if you are sending emails externally. Possible they have different limits set. If theclient.com domain is not your domain then the delivery failure says the server at that domain rejected the message.
0
 
LVL 20

Expert Comment

by:Svet Paperov
ID: 40442853
Are you able to send big messages internally – for an Exchange to an Exchange account?

What is the anti-spam / anti-virus solution?
0
 
LVL 32

Accepted Solution

by:
DrDamnit earned 0 total points
ID: 40598013
Turns out, this was a bug or configuration problem in Exchange itself. The most recent roll-up (December) fixed it.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question