external spam server, incoming to Zimbra (blocked)

I need to install an assp server in front of a zimbra server.
The spam server is being run in transparent mode on the same lan as Zimbra which is the MTA in the DNS records.

When I try sending an email from an external network, I am getting;
'relay attempt blocked' and '530 Relaying not allowed' on assp and on the zimbra server,

Sep 24 10:15:06 uc postfix/smtpd[18211]: connect from unknown[192.168.1.60]
Sep 24 10:15:06 uc postfix/smtpd[18211]: lost connection after MAIL from unknown[192.168.1.60]
Sep 24 10:15:06 uc postfix/smtpd[18211]: disconnect from unknown[192.168.1.60]

My local and any other relay networks are configured in zimbra yet it won't allow from the above local server. I've searched quite a lot and have found nothing which gives me a solution so time to post here.

Zimbra 8.0.6
projectsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sanga CollinsSystems AdminCommented:
In zimbra add 192.168.1.60 to the list of IPs on your MTA trusted networks

http://wiki.zimbra.com/wiki/ZimbraMtaMyNetworks
0
projectsAuthor Commented:
I do have the list of trusted networks but only in Configure/Servers/"myserver"/MTA/MTA trusted networks

However, I don't have anything set in Configure/Global Settings/MTA/MTA trusted networks.

Do you mean there?

I tried this also and same results.
0
projectsAuthor Commented:
I have noticed that sometimes, changing settings in the GUI does not seem to remain set when looking on command line.

In fact, even after setting this, I went to another page, then came back and the settings are no longer there. I am not sure what command sets the global trusted networks from the command line.

$ postconf mynetworks
mynetworks = 127.0.0.0/8 192.168.0.0/16 172.16.30.0/24 10.0.0.0/8 xx.xx.xx.xx/32

I tried adding the server IP in GUI but it doesn't stay. I then tried in CLI

zmprov ms myserver zimbraMtaMyNetworks '127.0.0.0/8 192.168.0.0/16 172.16.30.0/24 10.0.0.0/8 xx.xx.xx.xx/32 192.168.1.60/32'

but that didn't work either. Not sure how to set this globally from CLI.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

projectsAuthor Commented:
$ zmprov mcf zimbraMtaMyNetworks '127.0.0.0/8 192.168.0.0/16 172.16.30.0/24 10.0.0.0/8 192.168.1.60/32'

$ postconf mynetworks
mynetworks = 127.0.0.0/8 192.168.0.0/16 172.16.30.0/24 10.0.0.0/8 92.168.1.60/32

(Tried with an without reloading postfix)

$ postfix reload
/postfix-script: refreshing the Postfix mail system

This seems to be the way to set my networks globally but this also made no difference, the spam server was stick blocked in the same way.

In GUI, my networks still don't show up  in global settings, my trusted nets.
0
Sanga CollinsSystems AdminCommented:
the network 192.168.0.0/16 should take care of 192.168.1.60.

Is the 'relay attempt blocked' message appearing in the zimbra logs or only in the assp server?
0
projectsAuthor Commented:
The relay attempt is showing on assp.
On zimbra, all I see is the connect/disconnect message.
0
Sanga CollinsSystems AdminCommented:
Ok then Zimbra is probably not where you issue is. The connect disconnect message is correct for when a server attempts a connection but fails to do anything after that.

I have experience with Zimbra than assp, but I am going to reach out to a colleague to find more info so we can get your email flowing again.
0
Sanga CollinsSystems AdminCommented:
In the assp config do you have the following

Relaying section:
Accept All Mail* (acceptAllMail): enter your ip addresses here

and

Email interface section:
Authorized Addresses* (EmailAdmins): enter your domains here for example: @domain1.com|@domain2.com etc ...
0
projectsAuthor Commented:
acceptAllMail has all of my local and any external IP's which should be allowed.

127.0.0.1|10.|192.168.|172.16.|xx.xx.x.|x.x.x.x|x.x.x.

The second section looks as follows so I am not sure what to enter here since assp is sending TO zimbra.

Authorized Addresses* (EmailAdmins)

Mail from any of these addresses can add/remove to/from redlist, spamlovers, noprocessing, blacklist. May request an EmailBlockReport for a list of users. Accepts specific addresses (user@example.com), user parts (user) or entire domains (@example.com)
0
projectsAuthor Commented:
The spam server is trying to send so it must be zimbra stopping it no?
0
Sanga CollinsSystems AdminCommented:
Ok, lets break it down a little more. I think the first thing we need to be sure on is which server is responsible for preventing the mail flow.

When you say in the original post: " sending an email from an external network" Are you

a) sending outbound mail as a zimbra user from a computer or device that is on an external network (such as laptop or mobile)?
b) Receiving mail from and external network going to a zimbra user through the spam filter?
0
projectsAuthor Commented:
The problem was that assp didn't have an updated list of allowed domains so it was blocking incoming email to the mail server since it didn't know about the allowed domains.

The allowed domains list is a list of domains which are allowed to relay, either because they exist on the local network/mail server or are simply allowed to relay for other reasons.

What I meant by "sending an email from an external network" was that email was coming from an external source, such as any other network, not something we own or have control over such as yahoo, gmail, any other domain.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
projectsAuthor Commented:
Even though I found my own answer, your input helped so thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet / Email Software

From novice to tech pro — start learning today.