Freenas V9.2.0 Performance issue

Hi,

I'm using freenas V.9.2.0.issue is when i'm going to copy some files one hard disk  to another hard disk.it's take too much time to copy.same issue face in copy local system to freenas hard disk.
For example 1 GB file takes 9-10min.
Can you please give me some suggestion, what i will do to troubleshoot this problem?

Regards & Thanks,
xeroxzerox
LVL 6
xeroxzeroxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gheistCommented:
Check dmesg and SMART stsus - most likely some of your disks are failing (or at least losing DMA)
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Has your FreeNAS system always performed this bad or is this occurring now after some time?

How is your system setup? What kind of hardware are you using? If you were using USB drives for example then you would not get much performance.
0
xeroxzeroxAuthor Commented:
Hi,

Thanks & sorry for my delay response, it's comes after some times, I'm using below configuration
ProLiant ML110 G6
Processor: Intel(R) Xeon(R) CPU X3430 @ 2.40GHz
RAM: 8GB
NIC: 1
HDD:
1. Remove-able Pen Drive = 4GB (freenas installed )
2. Hdd 80GB ,1 TB,1 TB

Please guide me how to make copy fast and improve performance of freenas.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gheistCommented:
Make sure iLO does not share network card with system.

Are all of your drives with same interface - like SATA or SAS?

Since you have speed problems - size is meaningless... What are the RPMs of drives?
0
Gerwin Jansen, EE MVETopic Advisor Commented:
What's on that 80Gb drive? I'd install FreeNAS on that instead of running it from your Pen Drive. Are the 2 1TB drives in a RAID configuration and if so what? Your RAID controller or setup may not be supported by FreeNAS.
0
xeroxzeroxAuthor Commented:
I've not installed any raid in freenas. I'm only carry docs & applications in  80Gb HDD.
can you explain me, How to setup freenas which gives high performance of upper configuration system?

Thanks all of one,
0
gheistCommented:
You have too little memory for ZFS. Use UFS/ffs.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
I don't agree on gheist's memory statement.

From the FreeNAS manual:
FreeNAS® with ZFS
typically requires a minimum of 8 GB of RAM in order to provide good performance and stability.

@xeroxxerox - What do you mean by "it's comes after some times" - I don't understand.
0
xeroxzeroxAuthor Commented:
Hi ,

Thanks all of you.
I've followed below step, now i seems some performance increased in freenas.

#Assuming 8GB of memory
#If Ram = 4GB, set the value to 512M
#If Ram = 8GB, set the value to 1024M
vfs.zfs.arc_min="1024M"

#Ram x 0.5 - 512 MB
vfs.zfs.arc_max="3584M"

#Ram x 2
vm.kmem_size_max="16G"

#Ram x 1.5
vm.kmem_size="12G"

#The following were copied from FreeBSD ZFS Tunning Guide
#https://wiki.freebsd.org/ZFSTuningGuide

# Disable ZFS prefetching
# http://southbrain.com/south/2008/04/the-nightmare-comes-slowly-zfs.html
# Increases overall speed of ZFS, but when disk flushing/writes occur,
# system is less responsive (due to extreme disk I/O).
# NOTE: Systems with 4 GB of RAM or more have prefetch enabled by default.
vfs.zfs.prefetch_disable="1"

# Decrease ZFS txg timeout value from 30 (default) to 5 seconds.  This
# should increase throughput and decrease the "bursty" stalls that
# happen during immense I/O with ZFS.
# http://lists.freebsd.org/pipermail/freebsd-fs/2009-December/007343.html
# http://lists.freebsd.org/pipermail/freebsd-fs/2009-December/007355.html
# default in FreeBSD since ZFS v28
vfs.zfs.txg.timeout="5"

# Increase number of vnodes; we've seen vfs.numvnodes reach 115,000
# at times.  Default max is a little over 200,000.  Playing it safe...
# If numvnodes reaches maxvnode performance substantially decreases.
kern.maxvnodes=250000

# Set TXG write limit to a lower threshold.  This helps "level out"
# the throughput rate (see "zpool iostat").  A value of 256MB works well
# for systems with 4 GB of RAM, while 1 GB works well for us w/ 8 GB on
# disks which have 64 MB cache.

# NOTE: in v27 or below , this tunable is called 'vfs.zfs.txg.write_limit_override'.
vfs.zfs.write_limit_override=1073741824
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.