Remote Desktop Services

I am getting this message when connecting to my newly configures Server 2012 Remote Desktop role:

"Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable"
I can connect with no problem if I use internet explore on the server itself

Please advise with exact details please
doctorbillTechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Greg HejlPrincipal ConsultantCommented:
Try this:

http://www.howtonetworking.com/RemoteAccess/remoteapp2.htm

Configure Remote Desktop Gateway Settings  - Step by step
 
If you would like users to connect to the Remote Desktop Session Host (RD Session Host) server across a firewall through Remote Desktop Gateway (RD Gateway), you need to configure RD Gateway deployment settings. To configure RD Gateway settings, please follow these steps:

1. Open RemoteApp Manager by clicking Start, point to Administrative Tools, point to Remote Desktop Services, and then click RemoteApp Manager.
2. In the Actions pane of RemoteApp Manager, click RD Gateway Settings. (Or, in the Overview pane, next to RD Gateway Settings, click Change.)
3. On the RD Gateway tab, configure the desired RD Gateway behavior. You can configure whether to automatically detect RD Gateway server settings, to use RD Gateway server settings that you specify, or to not use an RD Gateway server.
If you select Automatically detect RD Gateway server settings, the client tries to use Group Policy settings to determine the behavior of client connections to RD Gateway.
If you select Use these RD Gateway server settings, do the following:
1. Configure the RD Gateway server name and the logon method.
Important
The server name must match what is specified in the Secure Sockets Layer (SSL) certificate for the RD Gateway server.
2. If you want the connection to try to use the same user credentials to access both the RD Gateway server and the RD Session Host server, select the Use the same user credentials for RD Gateway and RD Session Host server check box. However, users may still receive two prompts for credentials if conflicting credentials exist from any source such as Group Policy settings, and those credentials do not work. They may also receive two prompts for credentials if default credentials are used for the connection and those credentials do not work.
3. If you want the client computer to automatically detect when RD Gateway is required, select the Bypass RD Gateway server for local addresses check box. (Selecting this option optimizes client performance.)

To always use an RD Gateway server for client connections, clear the Bypass RD Gateway server for local addresses check box.
4. When you are finished, click OK.
0
doctorbillTechAuthor Commented:
Remote Desktop Services is not there
0
doctorbillTechAuthor Commented:
sorry - found it
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

doctorbillTechAuthor Commented:
3. On the RD Gateway tab, configure the desired RD Gateway behavior. You can configure whether to automatically detect RD Gateway server settings, to use RD Gateway server settings that you specify, or to not use an RD Gateway server.

Does the above apply to server 2012 ?
I cannot see any of this
0
doctorbillTechAuthor Commented:
Greg:
To elaborate

I can successfully use the RDWeb interface when I open the site on the server Internet explorer
example:
https://ticktockit-sbs/RDWeb
I can log on using user credentials such as: ticktock\Administrator and Password
I get the remote apps screen window and I can open them successfully

On a remote computer I can get as far as being able to see the remote apps window in a browser and being able to click on them. When I try to open them I get the message specified below:

"Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable"
0
doctorbillTechAuthor Commented:
This is all on server 2012 R2
0
Greg HejlPrincipal ConsultantCommented:
check IIS bindings, it should be an IP you have on your NIC.  

Also review firewall settings,

here's a nice guide with assistance from the author to a user having your similar issue:

http://ryanmangansitblog.com/2013/03/27/deploying-remote-desktop-gateway-rds-2012/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
doctorbillTechAuthor Commented:
Solution
0
doctorbillTechAuthor Commented:
Greg:
I spoke too soon
I followed your suggestions to the letter but still have exactly the same issue
0
Greg HejlPrincipal ConsultantCommented:
0
doctorbillTechAuthor Commented:
Already done
0
zimbomanCommented:
I have the same problem Server 2012 R2 - no solution as of yet...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.