Cannot connect new Windows 7 Computer to SBS Essentials 2011 Server

I am trying to connect a new Windows 7 computer to a SBS Essentials server.  I get the error that server cannot be found.  I dont know why, as I can get to the prompt where it asks for credentials and input user credentials and then I get the error.

I have done the following:

Made sure dns is working by pinging server by name.  No problem. No other computer is having any issue with DNS.
I did all of the troubleshooting that the link on that error stated to do.  Checked time on server and computer, removed .net framework, start the wss certificate service and made sure the net.tcp port sharing server is on.  Nothing works.

The fix for the error I get,  is to make sure the time matches between server and computer.  It does.  It still will not connect.
I am trying to connect as the user, an admin and still wont work.  I even created a local admin account the same as the domain account just to see if that is an issue.

Anyone seen this or can help?

Thanks in advance.
maximus7569Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
DNS can still be an issue if you have another Name Server in your tcp/ip settings. Make sure the SBS server is the only one. Also make sure your server and the Windows 7 PC are fully patched.
0
maximus7569Author Commented:
Yes they are both fully patched and pc only has server dns in there.  Any other ideas?
0
rindiCommented:
Yes. Disable any 3rd party firewall on the PC. With Windows builtin firewall there usually is no issue but 3rd party stuff can cause issues.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

JohnBusiness Consultant (Owner)Commented:
Make sure the computer is Windows Pro and not just Windows.

Look at the network connection, Properties and make sure Client for Microsoft Networks is installed and working.

Look in Control Panel, Network and Sharing Center and make certain the Network Card is set on Work and NOT on Public. Public will cause an issue.

Make sure Network Discovery and File and Print Sharing are both enabled.
0
maximus7569Author Commented:
Computer is Windows 7 Pro.  Let me try these ideas and I will let you guys know.

Thanks!
0
maximus7569Author Commented:
I tried all the above and still no go.
0
JohnBusiness Consultant (Owner)Commented:
Windows 7 should connect just fine.

Open cmd.exe and type NET USE Z: \\nameofserver\foldershare .  What error do you get?
Now type NET USE Z: \\ipaddressofserver\samefoldershare . What error do you get?

If the machine is very new, perhaps restore it to factory specs and try connecting before adding software.
0
maximus7569Author Commented:
I get no errors on both.  They both map with those commands.  Would that antivirus be causing the problem? I am using EST Antivirus.  Have no firewall or anything.  Windows firewall is turned off.
0
JohnBusiness Consultant (Owner)Commented:
If the folders map with commands, then recheck DNS and that the firewall at the server is truly disabled.

Also check the firewall on the Windows 7 machine.

Then on the Windows 7 machine, reset TCP/IP to see if that is causing an issue.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then Restart the computer and test
0
rindiCommented:
I haven't used eset, but many antivirus suites include a firewall. I'd just disable all of eset's options when connecting to the domain, and when successful, enable those you need again.
0
hecgomrecCommented:
If you are able to open a CMD and run the commands John H. gave you it means to me you are logged locally otherwise you won't be able to open a session with the server.

Where you ever able to add the machine to the domain?  Are you logged in using "DOMAIN\USERName"?

I will start by checking if the machine is register on the domain, if it is I will remove it, delete the account and start over.

Also, make sure the accounts you are using are not logged out.
0
maximus7569Author Commented:
I have not been able to get this computer connected. I have been logged in as local admin account to get it on the network hooked up.  I tried manually (which I know this is a no, no) and I got this error: The security database on the server does not have a computer account for this workstation trust relationship

I have never had this much trouble connecting a compuer to SBS domain.  Very strange.

Any other thoughts?
0
JohnBusiness Consultant (Owner)Commented:
If you have tried all the suggestions above, particular disjoining, restarting, and re-joining the domain, then (since this is a new machine) consider starting over (reinstalling Windows and get domain and connections working before adding software (particularly Anti Virus).
0
maximus7569Author Commented:
Ok John, thank you. I will try that.
0
hecgomrecCommented:
Well, I do connect all my machines manually.

If the machine seems to be in a domain just take out of it put it into any group (mygroup, workgroup, companyname) and try to change its name too.  Make sure you don't find the machine's name on the AD.  Reboot the machine and try to add it into the domain again.
0
JohnBusiness Consultant (Owner)Commented:
Another thing you could try is to make a new Domain User account on the machine and see if the new user can connect correctly.
0
hecgomrecCommented:
Sorry John! but if the machine is not in the AD he can't login a user from the Domain.

He must first join the machine to the domain.!!!
0
JohnBusiness Consultant (Owner)Commented:
I thought perhaps the machine had been joined.

If not on a domain, just make a new local Windows User Account and try the new user.
0
maximus7569Author Commented:
I just restored computer to factory and fixing to try a few of the above things.  I will let you guys know.  Thank you for all your help!
0
maximus7569Author Commented:
I keep getting this error after a clean install of computer before any software  is installed.
0
maximus7569Author Commented:
0
JohnBusiness Consultant (Owner)Commented:
Windows 7 Professional connects just fine to Server 2003 and up.

So at this point, it would appear something has gone wrong with the Server.

Can you uninstall ESET from the Server and any other non-essential software (e.g. like Adobe). Then run TCP/IP repair on the server (instructions above in this thread). Then restart the Server and test.
0
hecgomrecCommented:
Please make sure the computer's name is not longer than 15 characters and it doesn't have a "_" on it.

Date, time and time zone should match the server, if you are using http://servername/Connect, downloaded and start the software, username/password should be for the network user not local.
0
maximus7569Author Commented:
So the problem ended up being a bad cert on the server.  There were multiple self assigned certs and the wrong one was binded in IIS.  Once the correct one was binded the computer could now connect.    We are good to go now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.